[Plone-UI] Re: Typekit and Plone?

Rob Porter robzonenet at gmail.com
Tue Mar 23 21:12:57 UTC 2010


Thanks Denys that worked!!! Here is the solution. Put your css in main.css
or a css file found in the browser folder. Also stick in your font itself in
the same folder as the css file. Put something similar to this in your css
file



    @font-face {
      font-family: myfont;
      src: url('++resource++plonetheme.gatherit.stylesheets/MyFont.ttf');
      }

      #portal-header h2 a {
    font-family:  myfont;
}

I changed the name for the font i was using to "MyFont.ttf".

Thanks Denys I owe you a beer next time I see you. :)



On Tue, Mar 23, 2010 at 4:31 PM, Denys Mishunov <denys.mishunov at gmail.com>wrote:

> Hello Rob,
> On Mar 23, 2010, at 9:14 PM, Rob Porter wrote:
>
> > Does anyone have a work around for this. I tried putting my font files
> everywhere.. in the zmi root of my plone site, custom folder, in the plone
> site itself. I tested out the fonts on a hand typed html/css file on my
> desktop with no issues.
>
> Did you check
> http://dev.plone.org/collective/browser/xdvtheme.xdvrocks/trunk/xdvtheme/xdvrocks?
> This is the theme I have made for my talk at the last year's conference. It
> uses @font-face rules in
>
>
> http://dev.plone.org/collective/browser/xdvtheme.xdvrocks/trunk/xdvtheme/xdvrocks/skins/xdvtheme_xdvrocks_styles/main.css.dtml
>
> The fonts themselves are located in the same folder with the stylesheet.
> This worked in FF last time I checked. Please let me know if this doesn't
> work for you.
>
> Good luck.
>
> --
> Best regards,
> Denys Mishunov
>
> mailto:denys.mishunov at gmail.com
> IRC: spliter(#plone)
>
>
>
>
>
>
>


-- 
Rob Porter
http://robzone.net/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.plone.org/pipermail/plone-ui/attachments/20100323/2c9a90e1/attachment.html>


More information about the UI mailing list