[Plone-UI] Error: Macro expantions failed

Espen Moe-Nilssen espen at medialog.no
Thu Feb 5 14:04:08 UTC 2009


I think everybody gets that error, but it still works......


Den 4. feb. 2009 kl. 15.03 skrev pyf:

>
>
>
> chrissl wrote:
>>
>> Hi,
>>
>>   I´m trying to customize a file in folder  /portal_skins/custom/ 
>> file, but
>> it is not possible because of this error on the page: 	
>>
>> Macro expansion failed
>> exceptions.KeyError: 'hidden_macro'
>>
>> I´m using PLONE 3.0
>> Please do someone knows the meaning of this error ?
>>
>> thanks
>>
>>
>
>
> I've got the same error in ZMI:
> Macro expansion failed
> exceptions.KeyError: 'field_macro'
>
> When I custom a zpt file. This file calls macro
> portal_skins/archetypes/widgets/field_macro:
>
> <div metal:define-macro="body"
>              class="my-custom-at-body"
>                           tal:define="field_macro field_macro |
> here/widgets/field/macros/view;"
>                          ...>
>           ...
>                 <metal:use_field use-macro="field_macro" />
> </div>
>
> Any pointers appreciated.
>
> -- 
> View this message in context: http://n2.nabble.com/Error%3A-Macro- 
> expantions-failed-tp676008p2268909.html
> Sent from the User Interface & Design mailing list archive at  
> Nabble.com.
>
>
> _______________________________________________
> UI mailing list
> UI at lists.plone.org
> http://lists.plone.org/mailman/listinfo/ui

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.plone.org/pipermail/plone-ui/attachments/20090205/def25e7a/attachment.html>


More information about the UI mailing list