[Plone-UI] Greybox IE6 css

Silvestre Marcelo Huens s.huens at gmail.com
Tue Sep 30 19:18:49 UTC 2008


On Tue, Sep 30, 2008 at 12:33 PM, Espen Moe-Nilssen <espen at medialog.no> wrote:
> Hi
> Thanks for all the feedback.
> I have done css with AlphaImageLoader before but stopped (years ago) without
> remembering why.
> Is this very very slow / not always working (or maybe it was some mistake I
> did)?

"small"(?) limitation exists with the AlphaImageLoader, in particular
IE6 has a problem with garbage collection when it comes to CSS filters
(and number of leaks, the worst of which are related with JScript),
so, too many filters can drive you to slowness... other problem is the
cursor doesn't allow you to click the links inside of an element with
the filter applied (there is a work around for that).
in some projects I used this script
http://labs.unitinteractive.com/unitpngfix.php, (in most cases ) works
very well, very fast to deploy and see if is suitable for you.

I notice in your css code a possible error(for ie6), you have this:

<div class="box">
    <div class="frame">
        ....
    </div>
</div>

".box"  have a fix width (160px), the child ".frame" don't; ie6 set
blocks to 100% width by default and ".frame" have the shadow of the
image like background, so the shadow always is going to have a width
of 160px...
with a quick workaround (in your ie fixes and just for ie6) like:

.frame {
    width: 0.1%;
}

you can fix that...


regards...
Q.
-- 
Senior designer - Plone integrator
www.menttes.com




More information about the UI mailing list