[Testbot] Plone 5.0 - Python 2.7 - Build # 4149 - Fixed! - 0 failure(s)

jenkins at plone.org jenkins at plone.org
Mon Feb 9 00:27:55 UTC 2015


-------------------------------------------------------------------------------
Plone 5.0 - Python 2.7 - Build # 4149 - Fixed!
-------------------------------------------------------------------------------

http://jenkins.plone.org/job/plone-5.0-python-2.7/4149/


-------------------------------------------------------------------------------
CHANGES
-------------------------------------------------------------------------------

Repository: Products.CMFPlone
Branch: refs/heads/master
Date: 2015-02-08T18:00:54-06:00
Author: vangheem (vangheem) <vangheem at gmail.com>
Commit: https://github.com/plone/Products.CMFPlone/commit/25c204389023a0cc5c778200bdee94b40a6d9bbc

toolbar code not quite right, go back for now

Files changed:
M Products/CMFPlone/browser/templates/main_template.pt

diff --git a/Products/CMFPlone/browser/templates/main_template.pt b/Products/CMFPlone/browser/templates/main_template.pt
index 3f9c9f2..fd6d4cd 100644
--- a/Products/CMFPlone/browser/templates/main_template.pt
+++ b/Products/CMFPlone/browser/templates/main_template.pt
@@ -45,14 +45,28 @@
   <body tal:define="isRTL portal_state/is_rtl;
                     sl python:plone_layout.have_portlets('plone.leftcolumn', view);
                     sr python:plone_layout.have_portlets('plone.rightcolumn', view);
-                    body_class python:plone_layout.bodyClass(template, view);"
+                    body_class python:plone_layout.bodyClass(template, view);
+                    toolbar_class python:request.cookies.get('plone-toolbar', 'plone-toolbar-left pat-toolbar');"
         tal:attributes="class body_class;
                         dir python:isRTL and 'rtl' or 'ltr';
                         python:plone_view.patterns_settings()"
         id="visual-portal-wrapper">
 
-    <section id="edit-bar" role="toolbar" tal:replace="structure context/@@render-toolbar"
-             tal:on-error="structure string:Error rendering toolbar, try @@render-toolbar for info"/>
+    <section id="edit-bar" role="toolbar">
+      <div id="edit-zone" role="toolbar" tal:attributes="class toolbar_class">
+        <div class="plone-toolbar-container">
+          <a class="plone-toolbar-logo">
+            <img alt="Plone Toolbar" tal:attributes="src string:${portal_url}/++plone++static/plone-toolbarlogo.svg" />
+          </a>
+          <a class="plone-toolbar-switcher"><span>Left-Top switcher</span></a>
+          <nav role="navigation">
+            <ul>
+              <div tal:replace="structure provider:plone.toolbar">
+              </div>
+            </ul>
+        </div>
+      </div>
+    </section>
 
     <header id="portal-top" i18n:domain="plone">
       <div tal:replace="structure provider:plone.portaltop" />




-------------------------------------------------------------------------------


More information about the Testbot mailing list