<div dir="ltr">You have an object in your database that (directly or indirectly) requires that module.<div><br></div><div style>If you're upgrading and won't have a module available in the destination version, you need to eliminate all objects that use the module *before* upgrading.</div>

</div><div class="gmail_extra"><br><br><div class="gmail_quote">On Mon, Mar 11, 2013 at 3:11 AM, rups2603 <span dir="ltr"><<a href="mailto:shewalkar.rupesh@gmail.com" target="_blank">shewalkar.rupesh@gmail.com</a>></span> wrote:<br>

<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"> Hi I need upgrade plone 3.1.1 to plone 4.2.1 As part of the process I first<br>
removed products that aren't available in Plone 4 or aren't necessary<br>
anymore & after I export data from plone 3.1.1  & try import into Plone<br>
4.2.1  it giving me error As such "Error Value: No module named<br>
ShellExServer.utils"  even  though Product.ShellExserver product uninstall<br>
in plone 3.1.1<br>
<br>
Log entries:<br>
raceback (innermost last):<br>
  Module ZPublisher.Publish, line 126, in publish<br>
  Module ZPublisher.mapply, line 77, in mapply<br>
  Module ZPublisher.Publish, line 46, in call_object<br>
  Module OFS.ObjectManager, line 620, in manage_importObject<br>
  Module OFS.ObjectManager, line 638, in _importObjectFromFile<br>
  Module ZODB.ExportImport, line 92, in importFile<br>
  Module transaction._transaction, line 260, in savepoint<br>
  Module transaction._transaction, line 257, in savepoint<br>
  Module transaction._transaction, line 690, in __init__<br>
  Module ZODB.Connection, line 1123, in savepoint<br>
  Module ZODB.Connection, line 587, in _commit<br>
  Module ZODB.ExportImport, line 176, in _importDuringCommit<br>
ImportError: No module named ShellExServer.utils<br>
<br>
<br>
<br>
<br>
--<br>
View this message in context: <a href="http://plone.293351.n2.nabble.com/upgrade-plone-3-1-1-to-4-2-4-No-module-named-ShellExServer-utils-tp7563765.html" target="_blank">http://plone.293351.n2.nabble.com/upgrade-plone-3-1-1-to-4-2-4-No-module-named-ShellExServer-utils-tp7563765.html</a><br>


Sent from the Installation, Setup, Upgrades mailing list archive at Nabble.com.<br>
_______________________________________________<br>
Setup mailing list<br>
<a href="mailto:Setup@lists.plone.org">Setup@lists.plone.org</a><br>
<a href="https://lists.plone.org/mailman/listinfo/plone-setup" target="_blank">https://lists.plone.org/mailman/listinfo/plone-setup</a><br>
</blockquote></div><br></div>