[Setup] Overriding pinned egg version

Ciro Iriarte cyruspy at gmail.com
Mon Sep 30 14:29:52 UTC 2013


2013/9/30 Ciro Iriarte <cyruspy at gmail.com>:
> Hi!, answering inline:
>
> 2013/9/27 Maurits van Rees-3 [via Plone]
> <ml-node+s293351n7568029h32 at n2.nabble.com>:
>> Op 26-09-13 12:29, Ciro Iriarte schreef:
>>
>>> Hi!, per your suggestion I created versions-local.cfg with this content:
>>>
>>> --
>>> [versions]
>>> distribute = 0.6.49
>>> --
>>>
>>> Modified buildout.cfg as:
>>>
>>> --
>>> extends =
>>>      base.cfg
>>>      versions.cfg
>>>      versions-local.cfg
>>> --
>>>
>>> But buildout complains with the same error:
>>>
>>> --
>>> plone_buildout at intranet:~/zeocluster> bin/buildout
>>> While:
>>>    Installing.
>>>    Loading extensions.
>>> Error: There is a version conflict..
>>> We already have: distribute 0.6.28
>>> --
>>
>> It should work, but distribute, setuptools and zc.buildout versions can
>> cause problems like this.
>>
>> You may have a buildout setting that prevents you from checking for
>> newer versions.  Try 'bin/buildout -n' to see if that helps.  It
>> probably does not help, but it is fast to try.
>
> It doesn't make any difference.
>
>>
>> Otherwise, run 'python bootstrap.py' again (with the proper python
>> version for your buildout, so 2.6 or 2.7 in the case of Plone 4.3).
>>
>
> This is what I've done:
>
> plone_buildout at intranet:~/zeocluster> pwd
> /opt/Plone/zeocluster
> plone_buildout at intranet:~/zeocluster> /opt/Plone/Python-2.7/bin/python
> bootstrap.py
> Downloading http://pypi.python.org/packages/2.7/s/setuptools/setuptools-0.6c11-py2.7.egg
> Generated script '/opt/Plone/zeocluster/bin/buildout'.
>
> And now buildout could integrate collective.xmpp.chat!!, the weird
> thing is that distribute 0.6.34 was installed in the process, not the
> old 0.6.28, nor the 0.6.49 I specified.
>
>
>> If the bootstrap gives problems, try it with a fresh bootstrap for
>> zv.buildout 1.x:
>> http://downloads.buildout.org/1/bootstrap.py
>>
>> BTW, it seems very strange to me that an add-on (collective.xmpp.chat)
>> requires a newer version of distribute, as you say.  I would not expect
>> that.
>
> Maybe you can test it, not sure if the egg packager is the one that
> must fix that or I'm doing something wrong...
>
>>
>> I hope this helps,
>>
>> --
>> Maurits van Rees: http://maurits.vanrees.org/
>> Zest Software: http://zestsoftware.nl
>>
>> _______________________________________________
>
> Regards,
>
> --
> Ciro Iriarte
> http://cyruspy.wordpress.com
> --

Well, it was installed, but trying to use the module makes my test
site blow as follows:

Module ZPublisher.Publish, line 143, in publish
Module zope.event, line 31, in notify
Module zope.component.event, line 24, in dispatch
Module zope.component._api, line 136, in subscribers
Module zope.component.registry, line 321, in subscribers
Module zope.interface.adapter, line 585, in subscribers
Module collective.xmpp.core.subscribers.startup, line 54, in setUpAdminClient
Module collective.xmpp.core.subscribers.startup, line 27, in createAdminClient
Module collective.xmpp.core.client, line 160, in init
Module collective.xmpp.core.client, line 88, in init
Module zope.component._api, line 169, in getUtility
ComponentLookupError: (<InterfaceClass
collective.xmpp.core.interfaces.IZopeReactor>, '')

Probably the module is not compatible with Plone 4.3

Regards,

-- 
Ciro Iriarte
http://cyruspy.wordpress.com
--


More information about the Setup mailing list