[Setup] upgrade plone 3.1.1 to 4.2.4 No module named ShellExServer.utils

Steve McMahon steve at dcn.org
Tue Mar 12 03:53:19 UTC 2013


You have an object in your database that (directly or indirectly) requires
that module.

If you're upgrading and won't have a module available in the destination
version, you need to eliminate all objects that use the module *before*
upgrading.


On Mon, Mar 11, 2013 at 3:11 AM, rups2603 <shewalkar.rupesh at gmail.com>wrote:

>  Hi I need upgrade plone 3.1.1 to plone 4.2.1 As part of the process I
> first
> removed products that aren't available in Plone 4 or aren't necessary
> anymore & after I export data from plone 3.1.1  & try import into Plone
> 4.2.1  it giving me error As such "Error Value: No module named
> ShellExServer.utils"  even  though Product.ShellExserver product uninstall
> in plone 3.1.1
>
> Log entries:
> raceback (innermost last):
>   Module ZPublisher.Publish, line 126, in publish
>   Module ZPublisher.mapply, line 77, in mapply
>   Module ZPublisher.Publish, line 46, in call_object
>   Module OFS.ObjectManager, line 620, in manage_importObject
>   Module OFS.ObjectManager, line 638, in _importObjectFromFile
>   Module ZODB.ExportImport, line 92, in importFile
>   Module transaction._transaction, line 260, in savepoint
>   Module transaction._transaction, line 257, in savepoint
>   Module transaction._transaction, line 690, in __init__
>   Module ZODB.Connection, line 1123, in savepoint
>   Module ZODB.Connection, line 587, in _commit
>   Module ZODB.ExportImport, line 176, in _importDuringCommit
> ImportError: No module named ShellExServer.utils
>
>
>
>
> --
> View this message in context:
> http://plone.293351.n2.nabble.com/upgrade-plone-3-1-1-to-4-2-4-No-module-named-ShellExServer-utils-tp7563765.html
> Sent from the Installation, Setup, Upgrades mailing list archive at
> Nabble.com.
> _______________________________________________
> Setup mailing list
> Setup at lists.plone.org
> https://lists.plone.org/mailman/listinfo/plone-setup
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.plone.org/pipermail/plone-setup/attachments/20130311/89ec205a/attachment.html>


More information about the Setup mailing list