[Setup] Restore Plone Site

Serge Renfer serge.renfer at gmail.com
Thu Jan 24 11:03:35 UTC 2013


Your welcome !
serge


2013/1/24 George Tsiamis <gtsiamis1 at gmail.com>

> Serge, thanks ever so much for your advice. The command worked like a
> charm. Everything is up and running,
>
> All the best
>
> George
>
> On Jan 24, 2013, at 10:40 AM, "Serge Renfer [via Plone]" <[hidden email]<http://user/SendEmail.jtp?type=node&node=7562700&i=0>>
> wrote:
>
> James is right, you must first check the owner/group of the files :
> The easy way is to force all files to your "plone" user :
>
> sudo chown -R plone:plone *
>
> You must recover the blobstorage too :
>
> On the original instance, you create an archive :
>
> tar -cvpzf blobstorage.tar.gz blobstorage
>
> then you untar that archive to your new instance "var" folder:
>
> tar -xzf blobstorage.tar.gz
>
> serge
>
>
> 2013/1/24 James Glenn <<a
> href="x-msg://2673/user/SendEmail.jtp?type=node&node=7562691&i=0"
> target="_top" rel="nofollow" link="external">[hidden email]>
>
>> You might start by checking the permission of the files that you restored?
>>
>> Are the files still owned by user "plone"?
>> Your uid may not be recognizing the new "plone" user as the old "plone"
>> user?
>>
>>
>>
>> -Jim
>>
>>
>> On Jan 24, 2013, at 2:02 AM, George Tsiamis <<a
>> href="x-msg://2673/user/SendEmail.jtp?type=node&node=7562691&i=1"
>> target="_top" rel="nofollow" link="external">[hidden email]> wrote:
>>
>> > I have a Ubuntu 10.04 based computer that I am using as a web server
>> and on
>> > this computer I developed a web site using Plone. Recently I tried to
>> > upgrade to the most recent Ubuntu 12.10 but during the upgrade process
>> my
>> > computer crashed.
>> > Since I was having a back-up of my Plone site, that means all of my .cfg
>> > files plus the data.fs file I though that I was able to restore my Plone
>> > site. So what I did was:
>> >
>> > 1. Install on my computer Ubuntu 10.04 (went back to the old version)
>> >
>> > 2. Install Plone (my site was made with Plone 4.1 this time I install
>> the
>> > Plone 4.2 (latest version).
>> >
>> > 3. I create a Plone site
>> >
>> > 4. I copy all the .cfg files, the src folder and the Data.fs into the
>> > var/filestorage (no blobstorage file for me)
>> >
>> > 5. I run sudo python bootstrap.py
>> >
>> > 6. Run sudo ./bin/buildout. During that process all of things are being
>> > downloaded
>> >
>> > 7. At the end when I run sudo -u plone
>> > /usr/local/Plone/zinstance/bin/plonectl start
>> >
>> > I get the following message
>> >
>> > instance: Traceback (most recent call last):
>> >  File "/usr/local/Plone/zinstance/bin/plonectl", line 14, in <module>
>> >    plone.recipe.unifiedinstaller.ctl.main(server='',
>> clients=['instance'],
>> > location=r'/usr/local/Plone/zinstance',
>> > binDirectory=r'/usr/local/Plone/zinstance/bin',
>> > fileStorage=r'/usr/local/Plone/zinstance/var/filestorage/Data.fs')
>> >  File
>> >
>> "/usr/local/Plone/buildout-cache/eggs/plone.recipe.unifiedinstaller-4.1-py2.6.egg/plone/recipe/unifiedinstaller/ctl.py",
>> > line 120, in main
>> >    returncode = controller.runCommand(component, command)
>> >  File
>> >
>> "/usr/local/Plone/buildout-cache/eggs/plone.recipe.unifiedinstaller-4.1-py2.6.egg/plone/recipe/unifiedinstaller/ctl.py",
>> > line 83, in runCommand
>> >    po = subprocess.Popen(args)
>> >  File "/usr/lib/python2.6/subprocess.py", line 633, in __init__
>> >    errread, errwrite)
>> >  File "/usr/lib/python2.6/subprocess.py", line 1139, in _execute_child
>> >    raise child_exception
>> > OSError: [Errno 13] Permission denied
>> >
>> >
>> > I am really stack here. Any suggestions will be very much appreciated.
>> >
>> > Thanks in advance
>> >
>> > George
>> >
>> >
>> >
>> >
>> >
>> > --
>> > View this message in context:
>> http://plone.293351.n2.nabble.com/Restore-Plone-Site-tp7562689.html
>> > Sent from the Installation, Setup, Upgrades mailing list archive at
>> Nabble.com.
>> > _______________________________________________
>> > Setup mailing list
>> > <a
>> href="x-msg://2673/user/SendEmail.jtp?type=node&node=7562691&i=2"
>> target="_top" rel="nofollow" link="external">[hidden email]
>>
>> > https://lists.plone.org/mailman/listinfo/plone-setup
>>
>> _______________________________________________
>> Setup mailing list
>> <a
>> href="x-msg://2673/user/SendEmail.jtp?type=node&node=7562691&i=3"
>> target="_top" rel="nofollow" link="external">[hidden email]
>> https://lists.plone.org/mailman/listinfo/plone-setup
>>
>
>
> _______________________________________________
> Setup mailing list
> <a
> href="x-msg://2673/user/SendEmail.jtp?type=node&node=7562691&i=4"
> target="_top" rel="nofollow" link="external">[hidden email]
> https://lists.plone.org/mailman/listinfo/plone-setup
>
>
> ------------------------------
>  If you reply to this email, your message will be added to the discussion
> below:
> http://plone.293351.n2.nabble.com/Restore-Plone-Site-tp7562689p7562691.html
>  To unsubscribe from Restore Plone Site, click here.
> NAML<http://plone.293351.n2.nabble.com/template/NamlServlet.jtp?macro=macro_viewer&id=instant_html%21nabble%3Aemail.naml&base=nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.view.web.template.NodeNamespace&breadcrumbs=notify_subscribers%21nabble%3Aemail.naml-instant_emails%21nabble%3Aemail.naml-send_instant_email%21nabble%3Aemail.naml>
>
>
>
> ------------------------------
> View this message in context: Re: Restore Plone Site<http://plone.293351.n2.nabble.com/Restore-Plone-Site-tp7562689p7562700.html>
>
> Sent from the Installation, Setup, Upgrades mailing list archive<http://plone.293351.n2.nabble.com/Installation-Setup-Upgrades-f293353.html>at Nabble.com.
>
> _______________________________________________
> Setup mailing list
> Setup at lists.plone.org
> https://lists.plone.org/mailman/listinfo/plone-setup
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.plone.org/pipermail/plone-setup/attachments/20130124/69079426/attachment.html>


More information about the Setup mailing list