[Setup] Restore Plone Site

George Tsiamis gtsiamis1 at gmail.com
Thu Jan 24 08:02:03 UTC 2013


I have a Ubuntu 10.04 based computer that I am using as a web server and on
this computer I developed a web site using Plone. Recently I tried to
upgrade to the most recent Ubuntu 12.10 but during the upgrade process my
computer crashed.
Since I was having a back-up of my Plone site, that means all of my .cfg
files plus the data.fs file I though that I was able to restore my Plone
site. So what I did was:

1. Install on my computer Ubuntu 10.04 (went back to the old version)

2. Install Plone (my site was made with Plone 4.1 this time I install the
Plone 4.2 (latest version).

3. I create a Plone site

4. I copy all the .cfg files, the src folder and the Data.fs into the
var/filestorage (no blobstorage file for me)

5. I run sudo python bootstrap.py 

6. Run sudo ./bin/buildout. During that process all of things are being
downloaded

7. At the end when I run sudo -u plone
/usr/local/Plone/zinstance/bin/plonectl start

I get the following message

instance: Traceback (most recent call last):
  File "/usr/local/Plone/zinstance/bin/plonectl", line 14, in <module>
    plone.recipe.unifiedinstaller.ctl.main(server='', clients=['instance'],
location=r'/usr/local/Plone/zinstance',
binDirectory=r'/usr/local/Plone/zinstance/bin',
fileStorage=r'/usr/local/Plone/zinstance/var/filestorage/Data.fs')
  File
"/usr/local/Plone/buildout-cache/eggs/plone.recipe.unifiedinstaller-4.1-py2.6.egg/plone/recipe/unifiedinstaller/ctl.py",
line 120, in main
    returncode = controller.runCommand(component, command)
  File
"/usr/local/Plone/buildout-cache/eggs/plone.recipe.unifiedinstaller-4.1-py2.6.egg/plone/recipe/unifiedinstaller/ctl.py",
line 83, in runCommand
    po = subprocess.Popen(args)
  File "/usr/lib/python2.6/subprocess.py", line 633, in __init__
    errread, errwrite)
  File "/usr/lib/python2.6/subprocess.py", line 1139, in _execute_child
    raise child_exception
OSError: [Errno 13] Permission denied


I am really stack here. Any suggestions will be very much appreciated.

Thanks in advance

George





--
View this message in context: http://plone.293351.n2.nabble.com/Restore-Plone-Site-tp7562689.html
Sent from the Installation, Setup, Upgrades mailing list archive at Nabble.com.


More information about the Setup mailing list