[Setup] Application Could not import Products.Ploneboard

Servilio Afre Puentes afrepues at rhpcs.mcmaster.ca
Fri Apr 26 17:41:13 UTC 2013


"lumtegis ." <lumtegis at gmail.com> writes:

> Hi,
> After running bin/buildout on a Plone 4.0.6 install, i get the error below
> when attempting to start plone in debug mode

The version you are using won't with Plone < 4.1.

> $ bin/instance fg
> 2013-04-26 16:43:21 INFO ZServer HTTP server started at Fri Apr 26 16:43:21
> 2013
> Hostname: 0.0.0.0
> Port: 8080
> 2013-04-26 16:43:26 ERROR Application Could not import Products.Ploneboard
[...]
>   File
> "/home/tux/v_tuxPlone4/cip.buildout/eggs/Products.Ploneboard-3.3-py2.6.egg/Products/Ploneboard/PloneboardTool.py",
> line 2, in <module>
>     from AccessControl.class_init import InitializeClass
> ImportError: No module named class_init

This requires AccessControl 2.13, that was split into a separate package
in Zope2 2.13, but Plone 4.0 uses Zope2 2.12.

Possible solutions: either pin Ploneboard to version 2.2, or upgrade
Plone.

Servilio


More information about the Setup mailing list