[Setup] wrong architecture hints in zope.security?

Christoph Pingel pingelsan at googlemail.com
Mon Jun 18 08:48:35 UTC 2012


Hello,
I've stumbled over similar errors before, but I haven't a clue how to tell the compiler to compile for intel via buildout configuration.
The critical line seems to be:
/usr/libexec/gcc/powerpc-apple-darwin10/4.2.1/as: assembler (/usr/bin/../libexec/gcc/darwin/ppc/as or /usr/bin/../local/libexec/gcc/darwin/ppc/as) for architecture ppc not installed

Plone 4.1.4
Python 2.6.7

Thanks in advance for your help,
best regards,
Christoph




Searching for PasteDeploy
Reading http://pypi.python.org/simple/PasteDeploy/
Reading http://pythonpaste.org/deploy/
Reading http://pythonpaste.org/deploy/paste-deploy.html
Best match: PasteDeploy 1.5.0
Downloading http://pypi.python.org/packages/source/P/PasteDeploy/PasteDeploy-1.5.0.tar.gz#md5=f1a068a0b680493b6eaff3dd7690690f
Processing PasteDeploy-1.5.0.tar.gz
Writing /tmp/easy_install-Gvd7pm/PasteDeploy-1.5.0/setup.cfg
Running PasteDeploy-1.5.0/setup.py -q bdist_egg --dist-dir /tmp/easy_install-Gvd7pm/PasteDeploy-1.5.0/egg-dist-tmp-Xzo0eg

Installed /Users/plone/Instances/mysoftware/src/eo.base/PasteDeploy-1.5.0-py2.6.egg
Searching for Paste>=1.3
Reading http://pypi.python.org/simple/Paste/
Reading http://pythonpaste.org
Best match: Paste 1.7.5.1
Downloading http://pypi.python.org/packages/source/P/Paste/Paste-1.7.5.1.tar.gz#md5=7ea5fabed7dca48eb46dc613c4b6c4ed
Processing Paste-1.7.5.1.tar.gz
Writing /tmp/easy_install-bCiI61/Paste-1.7.5.1/setup.cfg
Running Paste-1.7.5.1/setup.py -q bdist_egg --dist-dir /tmp/easy_install-bCiI61/Paste-1.7.5.1/egg-dist-tmp-MfZJsF
warning: no previously-included files matching '*' found under directory 'docs/_build/_sources'

Installed /Users/plone/Instances/mysoftware/src/eo.base/Paste-1.7.5.1-py2.6.egg
Getting distribution for 'zope.security'.
/usr/libexec/gcc/powerpc-apple-darwin10/4.2.1/as: assembler (/usr/bin/../libexec/gcc/darwin/ppc/as or /usr/bin/../local/libexec/gcc/darwin/ppc/as) for architecture ppc not installed
Installed assemblers are:
/usr/bin/../libexec/gcc/darwin/x86_64/as for architecture x86_64
/usr/bin/../libexec/gcc/darwin/i386/as for architecture i386
src/zope/security/_proxy.c:1006: fatal error: error writing to -: Broken pipe
compilation terminated.
lipo: can't open input file: /var/tmp//ccErRaxp.out (No such file or directory)
error: Setup script exited with error: command 'gcc-4.2' failed with exit status 1
An error occurred when trying to install zope.security 3.8.3. Look above this message for any errors that were output by easy_install.
While:
  Installing.
  Getting section instance.
  Initializing section instance.
  Installing recipe plone.recipe.zope2instance.
  Getting distribution for 'zope.security'.
Error: Couldn't install: zope.security 3.8.3

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.plone.org/pipermail/plone-setup/attachments/20120618/b9c3d450/attachment.html>


More information about the Setup mailing list