[Setup] Error: Couldn't install: zope.interface 4.0.1

Servilio Afre Puentes afrepues at rhpcs.mcmaster.ca
Fri Jun 15 19:17:32 UTC 2012

Hola Héctor,

Recently I went through the trouble of making a Plone 3.3 buildout
work. The cause for all the issues I found along the way were add-ons
dependencies that were not pinned-down at that time that now with new
released versions would pull conflicting dependencies. Have you tried
making sure that all packages have version pinnings?

If you haven't, I can pass along the ones I came up with by looking at
good-py and other sources, I can publish the buildout to github.

On Fri, 15 Jun 2012 15:40:07 -0300, Héctor Velarde <hector.velarde at gmail.com> wrote:
> I'm writing a special buildout configuration to test a package under 
> Plone 3.3.x that looks like this:
> [buildout]
> extends =
>      http://svn.plone.org/svn/collective/buildout/plonetest/test-3.3.x.cfg
> package-name = sc.contentrules.groupbydate
> package-extras = [test]
> [test]
> defaults = ['-s', '${buildout:package-name}', '--auto-color', 
> '--auto-progress']
> [versions]
> plone.app.testing = 3.0a1
> but when I run it I got the following error message:
> (python-2.4)# hvelarde at hvelarde-laptop (origin:master * u=) 
> ~/plone/sc.contentrules.groupbydate
> # bin/buildout -c test-plone-3.3.x.cfg -vv
> Installing 'zc.buildout', 'setuptools'.
> We have the distribution that satisfies 'zc.buildout==1.4.4'.
> We have the distribution that satisfies 'distribute==0.6.15'.
> "/home/hvelarde/.buildout/eggs/distribute-0.6.15-py2.4.egg/setuptools/sandbox.py", 
> line 31, in <lambda>
>      {'__file__':setup_script, '__name__':'__main__'}
>    File "setup.py", line 42
>      except DistutilsPlatformError as e:
>                                     ^
> SyntaxError: invalid syntax

I used distribute 0.6.27 in my buildout, have you tried with that


More information about the Setup mailing list