[Setup] FW: Error: Couldn't install: zope.interface 3.6.3

Nathan Van Gheem vangheem at gmail.com
Tue Jun 5 18:48:37 UTC 2012


> But that got me further. I now have the instance in bin but I get an error
> when I try and start the server.
> daemon manager not running
> zopectl>
It's probably working. You just need to give it a command start or fg, etc.

> note:
> From all I've seen local distributions of Python are the way to go so I'm
> committed to working in this manner.
What do you mean? That's what buildout already does right. Gives you
all the package in a contained environment.

Using the system python is fine.



On Tue, Jun 5, 2012 at 1:24 PM, Aaron Rothenberg
<a_rothenberg at hotmail.com> wrote:
> In your eggs section you might also want to include "Pillow"
>
> I missed this. I'll try this first.
>
>
> ________________________________
> From: a_rothenberg at hotmail.com
> To: plone-setup at lists.plone.org
> Date: Tue, 5 Jun 2012 13:15:15 -0500
> Subject: [Setup] FW: Error: Couldn't install: zope.interface 3.6.3
>
>
>
>
> Thanks
>
> I've already set up a plone test site with  the unified installer. I used
> the system python2.7.2 and it worked fine.
>
> As for sudo apt-get install libxml2 libxml2-dev libxslt1-dev python-dev
> I noticed that it  put some  libs in the system pyhton2.7.2 path so ...?
> But that got me further. I now have the instance in bin but I get an error
> when I try and start the server.
> daemon manager not running
> zopectl>
>
> This same minimal buildout worked before using the system python.
>
> note:
> From all I've seen local distributions of Python are the way to go so I'm
> committed to working in this manner.
> Also, I need to set up Aspeli's environment with his buildout or else I
> can't continue using his  book that I bought.
>
> I know it's not recommended but I'm going to try over with a local 2.7 dist
> and see what happens.
> I'll  also try the IRC and see if someone else has encountered these
>  problems.
>
> Thanks again.
>
>
>
>
>> Date: Tue, 5 Jun 2012 11:57:22 -0500
>> Subject: Re: [Setup] Error: Couldn't install: zope.interface 3.6.3
>> From: vangheem at gmail.com
>> To: a_rothenberg at hotmail.com
>> CC: plone-setup at lists.plone.org
>>
>> Just a note, the easiest way to get setup quickly is to use the
>> unified installer http://plone.org/products/plone/releases/4.1.5
>>
>> What you're now running up against is not having the required lxml
>> libraries.
>>
>> for ubuntu what I *think* you'll need is something like this:
>>
>> sudo apt-get install libxml2 libxml2-dev libxslt1-dev python-dev
>>
>> In your eggs section you might also want to include "Pillow"
>>
>>
>> -Nathan
>>
>> On Tue, Jun 5, 2012 at 11:50 AM, Aaron Rothenberg
>> <a_rothenberg at hotmail.com> wrote:
>> >
>> > So I tried  ./bin/buildout -vv as per the suggestions.
>> >
>> > I re installed Ubuntu 11.10 with all the appropriate additions for Plone
>> > and
>> > python. Also, I am using a different  minimal buildout (below) which had
>> > previously worked with the Ubuntu system python(2.7.2) . It doesn't work
>> > anymore with the local 2.6* python.
>> >
>> > This is the end of the output
>> >
>> > Getting required 'lxml>=2.2.4'
>> >   required by plone.app.theming 1.0.
>> > We have no distributions for lxml that satisfies 'lxml>=2.2.4'.
>> > Getting distribution for 'lxml>=2.2.4'.
>> > Running easy_install:
>> > /home/aaron/.pythonbrew/venvs/Python-2.6/plone-python/bin/python "-c"
>> > "from
>> > setuptools.command.easy_install import main;main()" "-mUNxd"
>> > "/home/aaron/Plone4Book/MinimalBuildout/eggs/tmp2F9qTX"
>> > "/tmp/tmpBO4LaDget_dist/lxml-2.3.4.tgz"
>> >
>> > path=/home/aaron/Plone4Book/MinimalBuildout/eggs/setuptools-0.6c12dev_r88846-py2.6.egg
>> >
>> > Processing lxml-2.3.4.tgz
>> > Running lxml-2.3.4/setup.py -q bdist_egg --dist-dir
>> > /tmp/easy_install-JnFTNn/lxml-2.3.4/egg-dist-tmp-biCF11
>> > Building lxml version 2.3.4.
>> > Building without Cython.
>> > ERROR: /bin/sh: xslt-config: not found
>> >
>> > ** make sure the development packages of libxml2 and libxslt are
>> > installed
>> > **
>> >
>> > Using build configuration of libxslt
>> > In file included from src/lxml/lxml.etree.c:239:0:
>> > src/lxml/etree_defs.h:9:31: fatal error: libxml/xmlversion.h: No such
>> > file
>> > or directory
>> > compilation terminated.
>> > error: Setup script exited with error: command 'gcc' failed with exit
>> > status
>> > 1
>> > An error occurred when trying to install lxml 2.3.4. Look above this
>> > message
>> > for any errors that were output by easy_install.
>> > While:
>> >   Installing instance.
>> >   Getting distribution for 'lxml>=2.2.4'.
>> > Error: Couldn't install: lxml 2.3.4
>> >
>> >
>> >
>> > here's what I did from the start
>> > pythonbrew install 2.6
>> > then
>> > pythonbrew switch 2.6
>> > then
>> > cd MyPloneProject (where I have bootstrap.p and buildout.cfg)
>> > then
>> > python bootstrap.py  --distribute
>> > then
>> > bin/buildout  -vv
>> >
>> > I also  tried python 2.6.6,2.6.7 to run the bootstrap.
>> >
>> > I get this early on
>> > We have no distributions for ZODB3 that satisfies 'ZODB3>=3.9'.
>> >
>> > also I get a lot of these
>> > Note also that the installation directory must be on sys.path at runtime
>> > for
>> > this to work.  (e.g. by being the application's script directory, by
>> > being
>> > on
>> > PYTHONPATH, or by being added to sys.path by your code.)
>> >
>> > Here is the buildout:
>> > [buildout]
>> > extends =
>> > http://dist.plone.org/release/4.1/versions.cfg
>> > parts = instance
>> > [instance]
>> > recipe = plone.recipe.zope2instance
>> > user = admin:admin
>> > eggs = Plone
>> >
>> >
>> > Thanks for the help.
>> >
>> >> Date: Sun, 3 Jun 2012 16:37:58 -0500
>> >
>> >> Subject: Re: [Setup] Error: Couldn't install: zope.interface 3.6.3
>> >> From: vangheem at gmail.com
>> >> To: a_rothenberg at hotmail.com
>> >> CC: plone-setup at lists.plone.org
>> >>
>> >> What buildout are you running?
>> >>
>> >> Can you try running ./bin/buildout -vv
>> >>
>> >> to see what error you are getting in detail?
>> >>
>> >> On Sun, Jun 3, 2012 at 1:09 PM, Aaron Rothenberg
>> >> <a_rothenberg at hotmail.com> wrote:
>> >> > Thanks Nathan
>> >> >
>> >> > I do have the latest python-dev installation
>> >> >
>> >> > as per your suggestion, I used python-brew to install 2.6 and 2.6.6.
>> >> > I
>> >> > used
>> >> > both versions to  bootstrap.(then /bin/buildout)
>> >> >
>> >> > I still get the same error and I still don't  have anything new in
>> >> > bin(
>> >> > I
>> >> > was expecting at least "test" and "coverage").
>> >> >
>> >> > I may try and re-install Ubuntu 11.04 and go with that. Might that
>> >> > help?
>> >> >
>> >> > Thanks again.
>> >> >
>> >> >
>> >> >
>> >> >> Date: Sun, 3 Jun 2012 00:42:06 -0500
>> >> >> Subject: Re: [Setup] Error: Couldn't install: zope.interface 3.6.3
>> >> >> From: vangheem at gmail.com
>> >> >> To: a_rothenberg at hotmail.com
>> >> >> CC: plone-setup at lists.plone.org
>> >> >
>> >> >>
>> >> >> Do you have the python development package installed?
>> >> >>
>> >> >> sudo apt-get install python-dev
>> >> >>
>> >> >> If you're doing a buildout of plone 4.1, python 2.6 is what is
>> >> >> supported for that version.
>> >> >>
>> >> >>
>> >> >> Good luck,
>> >> >> Nathan
>> >> >>
>> >> >> On Sat, Jun 2, 2012 at 10:47 PM, Aaron Rothenberg
>> >> >> <a_rothenberg at hotmail.com> wrote:
>> >> >> > I'm using  Martin Aspeli's chapter3 bootstrap and buildout
>> >> >> > from Professional
>> >> >> > Plone 4
>> >> >> > Development.
>> >> >> >
>> >> >> > I'm in Ubuntu 12.04 and I'm using python 2.7.2 (if that matters).
>> >> >> > This
>> >> >> > machine is dedicated to this project so I 'm free to do
>> >> >> >  anything necessary
>> >> >> > to resolve this.
>> >> >> >
>> >> >> > The error is after I run bin/buildout from a  myPloneProject
>> >> >> > folder.
>> >> >> >
>> >> >> > the Bin created after the bootstrap  only has 1 buildout item
>> >> >> > ("buildout")
>> >> >> > in myPloneProject  after the failed bin/buildout.
>> >> >> >
>> >> >> > here is the output-
>> >> >> > Getting distribution for 'zope.interface==3.6.3'.
>> >> >> > error: None
>> >> >> > An error occured when trying to install zope.interface 3.6.3. Look
>> >> >> > above
>> >> >> > this message for any errors that were output by easy_install.
>> >> >> > While:
>> >> >> >   Installing.
>> >> >> >   Getting section instance.
>> >> >> >   Initializing section instance.
>> >> >> >   Installing recipe plone.recipe.zope2instance.
>> >> >> >   Getting distribution for 'zope.interface==3.6.3'.
>> >> >> > Error: Couldn't install: zope.interface 3.6.3
>> >> >> > *************** PICKED VERSIONS ****************
>> >> >> > [versions]
>> >> >> >
>> >> >> > *************** /PICKED VERSIONS ***************
>> >> >> >
>> >> >> > note: I have 2 decades in  development almost all in .net (some
>> >> >> > lamp)
>> >> >> > but
>> >> >> > I'm pretty new to python, eggs, buildouts...
>> >> >> >
>> >> >> > Thanks.
>> >> >> >
>> >> >> >
>> >> >> >
>> >> >> > _______________________________________________
>> >> >> > Setup mailing list
>> >> >> > Setup at lists.plone.org
>> >> >> > https://lists.plone.org/mailman/listinfo/plone-setup
>> >> >> >
>> >> >
>> >> > _______________________________________________
>> >> > Setup mailing list
>> >> > Setup at lists.plone.org
>> >> > https://lists.plone.org/mailman/listinfo/plone-setup
>> >> >
>> >
>> > _______________________________________________
>> > Setup mailing list
>> > Setup at lists.plone.org
>> > https://lists.plone.org/mailman/listinfo/plone-setup
>> >
>
> _______________________________________________ Setup mailing list
> Setup at lists.plone.org https://lists.plone.org/mailman/listinfo/plone-setup
>
> _______________________________________________
> Setup mailing list
> Setup at lists.plone.org
> https://lists.plone.org/mailman/listinfo/plone-setup
>


More information about the Setup mailing list