[Setup] Error: Couldn't install: zope.interface 3.6.3

Aaron Rothenberg a_rothenberg at hotmail.com
Mon Jun 4 04:21:47 UTC 2012


I'm rebuilding the machine.and running python bootstrap.py. I believe I also tried using a virtual python environment with the same results. Since I wasn't documenting my steps and I've already been butchering this Ubuntu with all sorts of pips,git,makes, easyinstalls... I figured I should just start from scratch. If it still error then I will post the results of /bin/buildout -vv  tomorrow.
I can also post the  buildout itself if that would help.
Thanks for responding.

Also, if this helps;I ran the buildout after switching to 2.6.6(and 2.6) via pythonbrewpythonbrew switch 2.6.6 https://github.com/utahta/pythonbrew 




> Date: Sun, 3 Jun 2012 16:37:58 -0500
> Subject: Re: [Setup] Error: Couldn't install: zope.interface 3.6.3
> From: vangheem at gmail.com
> To: a_rothenberg at hotmail.com
> CC: plone-setup at lists.plone.org
> 
> What buildout are you running?
> 
> Can you try running ./bin/buildout -vv
> 
> to see what error you are getting in detail?
> 
> On Sun, Jun 3, 2012 at 1:09 PM, Aaron Rothenberg
> <a_rothenberg at hotmail.com> wrote:
> > Thanks Nathan
> >
> > I do have the latest python-dev installation
> >
> > as per your suggestion, I used python-brew to install 2.6 and 2.6.6. I used
> > both versions to  bootstrap.(then /bin/buildout)
> >
> > I still get the same error and I still don't  have anything new in bin( I
> > was expecting at least "test" and "coverage").
> >
> > I may try and re-install Ubuntu 11.04 and go with that. Might that help?
> >
> > Thanks again.
> >
> >
> >
> >> Date: Sun, 3 Jun 2012 00:42:06 -0500
> >> Subject: Re: [Setup] Error: Couldn't install: zope.interface 3.6.3
> >> From: vangheem at gmail.com
> >> To: a_rothenberg at hotmail.com
> >> CC: plone-setup at lists.plone.org
> >
> >>
> >> Do you have the python development package installed?
> >>
> >> sudo apt-get install python-dev
> >>
> >> If you're doing a buildout of plone 4.1, python 2.6 is what is
> >> supported for that version.
> >>
> >>
> >> Good luck,
> >> Nathan
> >>
> >> On Sat, Jun 2, 2012 at 10:47 PM, Aaron Rothenberg
> >> <a_rothenberg at hotmail.com> wrote:
> >> > I'm using  Martin Aspeli's chapter3 bootstrap and buildout
> >> > from Professional
> >> > Plone 4
> >> > Development.
> >> >
> >> > I'm in Ubuntu 12.04 and I'm using python 2.7.2 (if that matters). This
> >> > machine is dedicated to this project so I 'm free to do
> >> >  anything necessary
> >> > to resolve this.
> >> >
> >> > The error is after I run bin/buildout from a  myPloneProject folder.
> >> >
> >> > the Bin created after the bootstrap  only has 1 buildout item
> >> > ("buildout")
> >> > in myPloneProject  after the failed bin/buildout.
> >> >
> >> > here is the output-
> >> > Getting distribution for 'zope.interface==3.6.3'.
> >> > error: None
> >> > An error occured when trying to install zope.interface 3.6.3. Look above
> >> > this message for any errors that were output by easy_install.
> >> > While:
> >> >   Installing.
> >> >   Getting section instance.
> >> >   Initializing section instance.
> >> >   Installing recipe plone.recipe.zope2instance.
> >> >   Getting distribution for 'zope.interface==3.6.3'.
> >> > Error: Couldn't install: zope.interface 3.6.3
> >> > *************** PICKED VERSIONS ****************
> >> > [versions]
> >> >
> >> > *************** /PICKED VERSIONS ***************
> >> >
> >> > note: I have 2 decades in  development almost all in .net (some lamp)
> >> > but
> >> > I'm pretty new to python, eggs, buildouts...
> >> >
> >> > Thanks.
> >> >
> >> >
> >> >
> >> > _______________________________________________
> >> > Setup mailing list
> >> > Setup at lists.plone.org
> >> > https://lists.plone.org/mailman/listinfo/plone-setup
> >> >
> >
> > _______________________________________________
> > Setup mailing list
> > Setup at lists.plone.org
> > https://lists.plone.org/mailman/listinfo/plone-setup
> >
 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.plone.org/pipermail/plone-setup/attachments/20120603/bd802d1d/attachment.html>


More information about the Setup mailing list