[Setup] Error: Couldn't install: zope.interface 3.6.3

Nathan Van Gheem vangheem at gmail.com
Sun Jun 3 05:42:06 UTC 2012


Do you have the python development package installed?

sudo apt-get install python-dev

If you're doing a buildout of plone 4.1, python 2.6 is what is
supported for that version.


Good luck,
Nathan

On Sat, Jun 2, 2012 at 10:47 PM, Aaron Rothenberg
<a_rothenberg at hotmail.com> wrote:
> I'm using  Martin Aspeli's chapter3 bootstrap and buildout from Professional
> Plone 4
> Development.
>
> I'm in Ubuntu 12.04 and I'm using python 2.7.2 (if that matters). This
> machine is dedicated to this project so I 'm free to do  anything necessary
> to resolve this.
>
> The error is after I run bin/buildout from a  myPloneProject folder.
>
> the Bin created after the bootstrap  only has 1 buildout item ("buildout")
> in myPloneProject  after the failed bin/buildout.
>
> here is the output-
> Getting distribution for 'zope.interface==3.6.3'.
> error: None
> An error occured when trying to install zope.interface 3.6.3. Look above
> this message for any errors that were output by easy_install.
> While:
>   Installing.
>   Getting section instance.
>   Initializing section instance.
>   Installing recipe plone.recipe.zope2instance.
>   Getting distribution for 'zope.interface==3.6.3'.
> Error: Couldn't install: zope.interface 3.6.3
> *************** PICKED VERSIONS ****************
> [versions]
>
> *************** /PICKED VERSIONS ***************
>
> note: I have 2 decades in  development almost all in .net (some lamp) but
> I'm pretty new to python, eggs, buildouts...
>
> Thanks.
>
>
>
> _______________________________________________
> Setup mailing list
> Setup at lists.plone.org
> https://lists.plone.org/mailman/listinfo/plone-setup
>


More information about the Setup mailing list