[Setup] zeoservice_install not working - solution

Joe Bigler jeb6 at psu.edu
Tue Mar 8 19:26:56 UTC 2011

I  tried installing Plone 4.02 on a server we have. Everything went fine, but
when I went to install the service for Zeo, I got this message.

C:\Program Files\Plone\bin>zeoserver_service install
Traceback (most recent call last):
  File "C:\Program Files\Plone\bin\zeoserver_service-script.py", line 39, in 
    import zeoserver_service
  File "C:\Program Files\Plone\bin\zeoserver_service.py", line 80, in 
    import win32service
ImportError: DLL load failed: The specified module could not be found. 

I found the solution. Plone's python needs to be in the Windows path
variable. I added c:\program files\plone\python to my path. I made sure
python.exe would start from the command prompt in C:\program
files\plone\bin. Then I ran zeoserver_service install. It said

C:\Program Files\Plone\bin>zeoserver_service install
Installing service ZEO_698716265
Service installed

Seems weird as running client1 install worked without python having to be in
the path.  I was able to install 1 zeo and 4 clients as services.

I saw a few posts asking about this when I was looking for the problem. 
Hope it helps.

View this message in context: http://plone.293351.n2.nabble.com/zeoservice-install-not-working-solution-tp6136848p6136848.html
Sent from the Installation, Setup, Upgrades mailing list archive at Nabble.com.

More information about the Setup mailing list