[Setup] Migrating content from 2.5 to recent using transmogrifier

Alex Clark aclark at aclark.net
Tue Mar 1 10:48:37 UTC 2011


On 2/28/11 6:50 PM, Martin Weigele wrote:
> Hi have been trying to transmogrify the content of a 2.5 Plone site upwards
> following closely the description at
>
> http://projects.quintagroup.com/products/wiki/quintagroup.transmogrifier/plone2-3#Additionalpackages
>
> which is however designed for Plone 2.1
>
> In the end, the start of the instance with bin/instance fg always results in
> the following error messages:
>
> bin/runzope -X debug-mode=on
> 2011-03-01 00:10:56 INFO ZServer HTTP server started at Tue Mar  1 00:10:56
> 2011
> 	Hostname: 0.0.0.0
> 	Port: 8080
>          ...
> 2011-03-01 00:10:56 ERROR PortalTransforms Problem importing module safe_html
> : No module named bbb.OFS_interfaces
>
> similar message repeated until it exits and backtraces. The site contains a
> couple of products that cannot be migrated directly, in particular
> quintagroups version of simple blog. Ideally I want to reach 4.0 and get rid
> of a specific blog product but keep historical urls intact.
>
> Any idea how this could be fixed?

Please paste the full traceback.

>
> Thanks, Martin
>


-- 
Alex Clark · http://aclark.net/help-me-help-plone



More information about the Setup mailing list