[Setup] setting permissions after collective.recipe.filestorage

Steve McMahon steve at dcn.org
Sun Feb 20 18:29:45 UTC 2011


Try adding a dummy reference in your [chown] part to something defined in
the part using c.r.filestorage.

On Sun, Feb 20, 2011 at 10:18 AM, Dominik <dominikruf at gmail.com> wrote:

>
> Hi,
>
> I use collective.recipe.filestorage to create multiple filestorages for
> multiple plone sites.
> My problem is that the directories/files created by
> collective.recipe.filestorage have the wrong owner.
> So I added
>
> [chown]
> recipe = plone.recipe.command
> command =
>    chown -R ${buildout:effective-user}:${buildout:effective-user}
> ${buildout:directory}/var/filestorage/
> update-command = ${chown:command}
>
> to my buildout.
> But somehow collective.recipe.filestorage is always executed last
>
> ...
> Updating zopeskel.
> Updating backup.
> Updating chown-zeo.
> chown-zeo: Running echo Dummy references to force this to execute after
> referenced parts
> echo /usr/local/Plone/zeocluster/var/backups
> chmod 600 .installed.cfg
> touch /usr/local/Plone/zeocluster/var/zeoserver/zeoserver.log
> find /usr/local/Plone/zeocluster/var -type d -exec chmod 700 {} \;
> chmod 744 //usr/local/Plone/zeocluster/bin/*
> Dummy references to force this to execute after referenced parts
> /usr/local/Plone/zeocluster/var/backups
> Installing chown.
> chown: Running '
> chown -R plone:plone /usr/local/Plone/zeocluster/var/filestorage/'
> Unused options for chown: 'update-command'.
> Updating osxcontroller.
> Updating unifiedinstaller.
> Updating filestorage.
> *************** PICKED VERSIONS ****************
> ...
>
> Does somebody know how I can force the chown part to execute after
> filestorage?
>
> cheers
> Dominik
> --
> View this message in context:
> http://plone.293351.n2.nabble.com/setting-permissions-after-collective-recipe-filestorage-tp6046274p6046274.html
> Sent from the Installation, Setup, Upgrades mailing list archive at
> Nabble.com.
> _______________________________________________
> Setup mailing list
> Setup at lists.plone.org
> https://lists.plone.org/mailman/listinfo/setup
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.plone.org/pipermail/setup/attachments/20110220/675bd890/attachment.html>


More information about the Setup mailing list