[Setup] Problem with old Plone 3.3.5 buildout

Eggert Ehmke eggert.ehmke at berlin.de
Sun Feb 13 17:19:37 UTC 2011


I have a website running on Plone 3.3.5 where I want to install the latest 
hotfix. I inserted the hotfix in the eggs section and started bin/buildout. 
Now I get those error messages:

Installing 'zc.buildout', 'setuptools'.
We have the distribution that satisfies 'zc.buildout==1.4.3'.
We have the distribution that satisfies 'setuptools==0.6c11'.
Installing 'plone.recipe.zope2install'.
We have the distribution that satisfies 'plone.recipe.zope2install==3.2'.
Installing 'plone.recipe.distros'.
We have the best distribution that satisfies 'plone.recipe.distros'.
Picked: plone.recipe.distros = 1.5
Installing '\ninfrae.subversion'.
We have the best distribution that satisfies 'infrae.subversion'.
Picked: infrae.subversion = 1.4.5
Getting required 'py'
  required by infrae.subversion 1.4.5.
Getting distribution for 'py'.
Running easy_install:
/usr/local/python-2.4.6/bin/python "-c" "from setuptools.command.easy_install 
import main; main()" "-mUNxd" "/srv/buildout/<myportal>/eggs/tmpFarXAO" "-q" 
"/tmp/tmpxsMvnAget_dist/py-1.4.1.zip"
path=/srv/buildout/<myportal>/eggs/setuptools-0.6c11-py2.4.egg

usage: -c [options] requirement_or_url ...
   or: -c --help

error: invalid command 'easy_install'
An error occured when trying to install py 1.4.1. Look above this message for 
any errors that were output by easy_install.
While:
  Installing.
  Getting section instance.
  Initializing section instance.
  Getting option instance:products.
  Getting section svnproducts.
  Initializing section svnproducts.
  Installing recipe 
infrae.subversion.
  Getting distribution for 'py'.
Error: Couldn't install: py 1.4.1

What may be broken? Whats bad about my easy_install, and how can I fix it 
safely? If needed, I can provide my buildout.cfg.

Regards,
Eggert


More information about the Setup mailing list