[Setup] Upgrade from 3.2.2 to 4.0.2 fails > Solved

Maurits van Rees m.van.rees at zestsoftware.nl
Mon Feb 7 17:22:13 UTC 2011


Op 06-02-11 16:44, Michael Zimmermann schreef:
> Hi there,
>
> after some more digging I was finally able to hunt this down.  The
> Stacktrace below hinted that the upgrade procedure is not able to
> relocate an item called "gp". What I did was as follows:
>
> - Deleting this object did not help.
> - As the traceback hints at the catalog, rebuilding the index
>    and running migration again lead to errors like "Broken
>    TextIndex". Many of them!
> - Looking at portal_catalog I could see that two indexes
>    (Title, Description) were of type "TextIndex". A type
>    which is no longer supported, see bug #11418
> - So, recreate these indexes as ZCTextIndex and rebuild  the catalog
> - Finally, the migration works....
>
> Nice.... now this major hurdle is taken...

Good to hear!

> On towards the smaller ones like finding out why the review portlet
> shows every published item as "to be reviewed" and some such..
>
> btw - this nabble-mailman-thing is a royal PITA. How do I really
> subscribe to this thing? And how do I make sure I do get each post once
> - and not never or twice....

Near the top of http://plone.org/support/forums/setup there is a link to 
this page with more info about how to really subscribe:
http://plone.293351.n2.nabble.com/mailing_list/MailingListOptions.jtp?forum=293353

This link should work as well, but it looks like some redirection is not 
setup correctly, so it does not work at the moment:
http://lists.plone.org/mailman/listinfo/setup

I myself use the Thunderbird email client and use that to subscribe to 
the gmane.comp.web.zope.plone.setup mailinglist-to-newsgroup gateway.


>> Traceback (most recent call last):
>>
>> ....
>>
>> "/opt/plone4/buildout-cache/eggs/Zope2-2.12.13-py2.6-linux-i686.egg/Products/ZCatalog/CatalogBrains.py",
>> line 92, in getObject
>>      target = parent.restrictedTraverse(path[-1])
>>    File
>> "/opt/plone4/buildout-cache/eggs/Zope2-2.12.13-py2.6-linux-i686.egg/OFS/Traversable.py",
>> line 310, in restrictedTraverse
>>      return self.unrestrictedTraverse(path, default, restricted=True)
>>    File
>> "/opt/plone4/buildout-cache/eggs/Zope2-2.12.13-py2.6-linux-i686.egg/OFS/Traversable.py",
>> line 293, in unrestrictedTraverse
>>      raise e
>> NotFound: gp
>> End of upgrade path, migration has finished

Solved already, but for the record: this points to an inconsistency in 
the portal_catalog: an item is in the portal_catalog but it does not 
exist in the real live site.  A Clear And Rebuild of the catalog on the 
Advanced tab while still in Plone 3 should have fixed this as well (but 
it can take a while if you have a large site).


-- 
Maurits van Rees
Web App Programmer at Zest Software: http://zestsoftware.nl
Personal website: http://maurits.vanrees.org/



More information about the Setup mailing list