[Setup] Migration Problem "exceptions.AttributeError: manage_addTool"

Doodeff info at axooh.ch
Tue Feb 9 06:13:51 UTC 2010


Dear Community 

I'm migrating a Plone Site from the very old version 2.0.5 to the newest
version. Like many others as well, I have serious problems with the
migration step from 2.0.5 to 2.1.4. 

My setup: I deinstalled all products within the Plone Site Configuration and
moved the Data.fs to the new instance 2.1.4 which is installed on the same
Zope server (2.7.0) like the 2.0.5 instance. 

In the new instance I try to migrate via "plone_migration" and there I get
the following error: 



Starting the migration from version: 2.0.5 
Attempting to upgrade from: 2.0.5 
Upgrade aborted 
Error type: exceptions.AttributeError 
Error value: manage_addTool 
File "C:\Programme\Plone 2\Data\Products\CMFPlone\MigrationTool.py", line
274, in upgrade newv, msgs = self._upgrade(newv) 
File "C:\Programme\Plone 2\Data\Products\CMFPlone\MigrationTool.py", line
371, in _upgrade res = function(self.aq_parent) 
File "C:\Programme\Plone
2\Data\Products\CMFPlone\migrations\v2_1\alphas.py", line 65, in
two05_alpha1 installATContentTypes(portal, out) 
File "C:\Programme\Plone
2\Data\Products\CMFPlone\migrations\v2_1\alphas.py", line 273, in
installATContentTypes installOrReinstallProduct(portal, product_name, out) 
File "C:\Programme\Plone
2\Data\Products\CMFPlone\migrations\migration_util.py", line 79, in
installOrReinstallProduct qi.installProduct(product_name) 
File "C:\Programme\Plone
2\Data\Products\CMFQuickInstallerTool\QuickInstallerTool.py", line 319, in
installProduct res=install(portal, reinstall=reinstall) 
File "C:\Programme\Plone
2\Zope\lib\python\Products\ExternalMethod\ExternalMethod.py", line 224, in
__call__ try: return f(*args, **kw) 
File "C:\Programme\Plone
2\Data\Products\ATContentTypes\Extensions\Install.py", line 57, in install
tool = installTool(self, out) 
File "C:\Programme\Plone
2\Data\Products\ATContentTypes\Extensions\Install.py", line 178, in
installTool addTool =
self.manage_addProduct['ATContentTypes'].manage_addTool 
End of upgrade path, migration has finished 
The upgrade path did NOT reach current version 
Migration has failed 




I tried several other setups (e.g. exporting and importing plone object as
*.zexp) but always got the same error. 

There seems to be a problem with the ATContentTypes, but I just don't have a
clue... does anybody can help me? Any hints? Any experiences? 
-- 
View this message in context: http://n2.nabble.com/Migration-Problem-exceptions-AttributeError-manage-addTool-tp4539487p4539487.html
Sent from the Installation, Setup, Upgrades mailing list archive at Nabble.com.



More information about the Setup mailing list