[Setup] "But I thought I removed singing and dancing" and other quickinstaller challenges

dgroos djgroos at gmail.com
Sat Oct 17 21:10:06 UTC 2009


Am trying to revive a previous plone 3.1.7 site.  Have run bin/buildout. Have
imported the old Data.fs.  Made many changes to buildout.cfg with
accompanying bin/buildout's.  The site starts.  The problem is that I can
only reinstall about half of the products (either through the ZMI
quickinstaller or Site Setup Add/Remove Products).  

For example, when I try to install Feedmixer through Add/Remove Products I
get this error:

Traceback (innermost last):
  Module ZPublisher.Publish, line 125, in publish
  Module Zope2.App.startup, line 238, in commit
  Module transaction._manager, line 96, in commit
  Module transaction._transaction, line 395, in commit
  Module transaction._transaction, line 495, in _commitResources
  Module ZODB.Connection, line 510, in commit
  Module ZODB.Connection, line 555, in _commit
  Module ZODB.Connection, line 582, in _store_objects
  Module ZODB.serialize, line 407, in serialize
  Module ZODB.serialize, line 416, in _dump
PicklingError: Can't pickle <class 'collective.singing.interfaces.ISalt'>:
import of module collective.singing.interfaces failed

This is strange as I removed singing stuff from the buildout.cfg and have no
files with the words "singing" or "dancing" in them.  Google doesn't seem to
have much to say about this particular error message.  Any ideas?

Next, when I try and install SimpleAttachment I got a KupuError.  googling
led me to Go to kupu_library_tool->Resource Types and change "linkable" to
"are not added to selection" and save.  This allowed me to add
SimpleAttachement successfully.

Next, when I try to add Ploneboard I got this:
Traceback (innermost last):
  Module ZPublisher.Publish, line 119, in publish
  Module ZPublisher.mapply, line 88, in mapply
  Module ZPublisher.Publish, line 42, in call_object
  Module Products.CMFQuickInstallerTool.QuickInstallerTool, line 584, in
installProducts
  Module Products.CMFQuickInstallerTool.QuickInstallerTool, line 509, in
installProduct
   - __traceback_info__: ('Ploneboard',)
  Module Products.ExternalMethod.ExternalMethod, line 231, in __call__
   - __traceback_info__: ((<PloneSite at /gcos>,), {}, (False,))
  Module
/srv/rhs_plone/eggs/Products.Ploneboard-2.0.1-py2.4.egg/Products/Ploneboard/Extensions/Install.py,
line 10, in install
  Module Products.GenericSetup.tool, line 390, in
runAllImportStepsFromProfile
   - __traceback_info__: profile-Products.Ploneboard:ploneboard
  Module Products.GenericSetup.tool, line 1182, in
_runImportStepsFromContext
  Module Products.GenericSetup.tool, line 1093, in _doRunImportStep
   - __traceback_info__: toolset
  Module Products.GenericSetup.tool, line 128, in importToolset
TypeError: 'NoneType' object is not callable

Note, this is a different error before succeeding in Adding
SimpleAttachment.  Any thoughts about Feedmixer or Ploneboard?  I've got a
couple other products that won't add, but a few problems at a time :)

Thanks!
David
-- 
View this message in context: http://n2.nabble.com/But-I-thought-I-removed-singing-and-dancing-and-other-quickinstaller-challenges-tp3842143p3842143.html
Sent from the Installation, Setup, Upgrades mailing list archive at Nabble.com.



More information about the Setup mailing list