[Setup] Plone4 dev buildout fails building Zope 2.12.0 while running Python2.6 Ubuntu 8.0.4 LTS Server

"Stroß-Radschinski Armin C." developer at acsr.de
Mon Oct 12 20:31:59 UTC 2009


Hi list,
I am stucked getting Plone4 dev up. My issue building Zope 2.12.0  
while running Plone4 dev buildout with http://svn.plone.org/svn/plone/buildouts/plone-coredev/branches/4.0

I still use svn 1.4.6 because the toubles with old instances and new  
svn. I only know about upward issues with old setuptools using svn  
1.5.x and 1.6.x.

any ideas?


System infos:
We are running on Linux with  "Ubuntu 8.0.4 LTS Server", with  
selfcompiled Python 2.6.3 invoked for the instance bootstrap.py via a  
local virtualenv and option --no-site-packages.

My buildout fails with:

bin/buildout -v
Installing 'mr.developer', 'buildout.dumppickedversions'.
We have the distribution that satisfies 'mr.developer==1.1'.
We have the best distribution that satisfies  
'buildout.dumppickedversions'.
Picked: buildout.dumppickedversions = 0.4
mr.developer: Skipped checkout of existing package 'Plone'.
mr.developer: Skipped checkout of existing package  
'Products.ATContentTypes'.
mr.developer: Skipped checkout of existing package  
'Products.Archetypes'.
mr.developer: Skipped checkout of existing package  
'Products.CMFActionIcons'.
mr.developer: Skipped checkout of existing package  
'Products.CMFCalendar'.
mr.developer: Skipped checkout of existing package 'Products.CMFCore'.
mr.developer: Skipped checkout of existing package  
'Products.CMFDefault'.
mr.developer: Skipped checkout of existing package  
'Products.CMFDiffTool'.
mr.developer: Skipped checkout of existing package  
'Products.CMFDynamicViewFTI'.
mr.developer: Skipped checkout of existing package  
'Products.CMFEditions'.
mr.developer: Skipped checkout of existing package  
'Products.CMFFormController'.
mr.developer: Skipped checkout of existing package  
'Products.CMFPlacefulWorkflow'.
mr.developer: Skipped checkout of existing package  
'Products.CMFQuickInstallerTool'.
mr.developer: Skipped checkout of existing package  
'Products.CMFTestCase'.
mr.developer: Skipped checkout of existing package 'Products.CMFTopic'.
mr.developer: Skipped checkout of existing package 'Products.CMFUid'.
mr.developer: Skipped checkout of existing package  
'Products.DCWorkflow'.
mr.developer: Skipped checkout of existing package  
'Products.ExtendedPathIndex'.
mr.developer: Skipped checkout of existing package  
'Products.ExternalEditor'.
mr.developer: Skipped checkout of existing package 'Products.Marshall'.
mr.developer: Skipped checkout of existing package  
'Products.MimetypesRegistry'.
mr.developer: Skipped checkout of existing package  
'Products.PasswordResetTool'.
mr.developer: Skipped checkout of existing package  
'Products.PlacelessTranslationService'.
mr.developer: Skipped checkout of existing package 'Products.PlonePAS'.
mr.developer: Skipped checkout of existing package  
'Products.PloneTestCase'.
mr.developer: Skipped checkout of existing package  
'Products.PluggableAuthService'.
mr.developer: Skipped checkout of existing package  
'Products.PluginRegistry'.
mr.developer: Skipped checkout of existing package  
'Products.PortalTransforms'.
mr.developer: Skipped checkout of existing package  
'Products.ResourceRegistries'.
mr.developer: Skipped checkout of existing package 'Products.TinyMCE'.
mr.developer: Skipped checkout of existing package  
'Products.ZopeVersionControl'.
mr.developer: Skipped checkout of existing package 'Products.kupu'.
mr.developer: Skipped checkout of existing package  
'Products.validation'.
mr.developer: Skipped checkout of existing package 'archetypes.kss'.
mr.developer: Skipped checkout of existing package  
'archetypes.referencebrowserwidget'.
mr.developer: Skipped checkout of existing package 'borg.localrole'.
mr.developer: Skipped checkout of existing package 'five.customerize'.
mr.developer: Skipped checkout of existing package 'kss.core'.
mr.developer: Skipped checkout of existing package 'plone.app.content'.
mr.developer: Skipped checkout of existing package  
'plone.app.contentrules'.
mr.developer: Skipped checkout of existing package  
'plone.app.controlpanel'.
mr.developer: Skipped checkout of existing package  
'plone.app.customerize'.
mr.developer: Skipped checkout of existing package 'plone.app.form'.
mr.developer: Skipped checkout of existing package  
'plone.app.jquerytools'.
mr.developer: Skipped checkout of existing package 'plone.app.kss'.
mr.developer: Skipped checkout of existing package 'plone.app.layout'.
mr.developer: Skipped checkout of existing package 'plone.app.locales'.
mr.developer: Skipped checkout of existing package 'plone.app.openid'.
mr.developer: Skipped checkout of existing package 'plone.app.portlets'.
mr.developer: Skipped checkout of existing package 'plone.app.upgrade'.
mr.developer: Skipped checkout of existing package  
'plone.app.viewletmanager'.
mr.developer: Skipped checkout of existing package  
'plone.app.vocabularies'.
mr.developer: Skipped checkout of existing package 'plone.memoize'.
mr.developer: Skipped checkout of existing package 'plone.protect'.
mr.developer: Skipped checkout of existing package  
'plone.recipe.zope2instance'.
mr.developer: Skipped checkout of existing package 'plone.session'.
mr.developer: Skipped checkout of existing package 'plone.stringinterp'.
mr.developer: Skipped checkout of existing package 'plone.theme'.
mr.developer: Skipped checkout of existing package  
'plonetheme.sunburst'.
mr.developer: Skipped checkout of existing package 'wicked'.
Installing 'zc.buildout', 'setuptools'.
We have the distribution that satisfies 'zc.buildout==1.4.1'.
We have the distribution that satisfies 'setuptools==0.6c9'.
Develop: '/home/goa/instances/triplefox4.0/src/ 
Products.CMFFormController'
Develop: '/home/goa/instances/triplefox4.0/src/Products.CMFTestCase'
Develop: '/home/goa/instances/triplefox4.0/src/ 
Products.CMFDynamicViewFTI'
Develop: '/home/goa/instances/triplefox4.0/src/ 
plone.recipe.zope2instance'
Develop: '/home/goa/instances/triplefox4.0/src/Products.DCWorkflow'
Develop: '/home/goa/instances/triplefox4.0/src/plone.theme'
Develop: '/home/goa/instances/triplefox4.0/src/plone.memoize'
Develop: '/home/goa/instances/triplefox4.0/src/Products.CMFTopic'
Develop: '/home/goa/instances/triplefox4.0/src/Products.CMFEditions'
Develop: '/home/goa/instances/triplefox4.0/src/plone.app.contentrules'
Develop: '/home/goa/instances/triplefox4.0/src/Products.Archetypes'
Develop: '/home/goa/instances/triplefox4.0/src/ 
Products.MimetypesRegistry'
Develop: '/home/goa/instances/triplefox4.0/src/plone.app.content'
Develop: '/home/goa/instances/triplefox4.0/src/five.customerize'
Develop: '/home/goa/instances/triplefox4.0/src/Products.TinyMCE'
Develop: '/home/goa/instances/triplefox4.0/src/Products.kupu'
Develop: '/home/goa/instances/triplefox4.0/src/plone.app.upgrade'
Develop: '/home/goa/instances/triplefox4.0/src/Products.CMFDiffTool'
Develop: '/home/goa/instances/triplefox4.0/src/Products.validation'
Develop: '/home/goa/instances/triplefox4.0/src/plone.app.kss'
Develop: '/home/goa/instances/triplefox4.0/src/ 
Products.PlacelessTranslationService'
Develop: '/home/goa/instances/triplefox4.0/src/ 
Products.PasswordResetTool'
Develop: '/home/goa/instances/triplefox4.0/src/ 
Products.CMFQuickInstallerTool'
Develop: '/home/goa/instances/triplefox4.0/src/plonetheme.sunburst'
Develop: '/home/goa/instances/triplefox4.0/src/ 
Products.PortalTransforms'
Develop: '/home/goa/instances/triplefox4.0/src/Products.CMFDefault'
Develop: '/home/goa/instances/triplefox4.0/src/plone.app.customerize'
Develop: '/home/goa/instances/triplefox4.0/src/Products.ExternalEditor'
Develop: '/home/goa/instances/triplefox4.0/src/Products.PluginRegistry'
Develop: '/home/goa/instances/triplefox4.0/src/plone.app.controlpanel'
Develop: '/home/goa/instances/triplefox4.0/src/plone.app.viewletmanager'
Develop: '/home/goa/instances/triplefox4.0/src/ 
Products.ExtendedPathIndex'
Develop: '/home/goa/instances/triplefox4.0/src/wicked'
Develop: '/home/goa/instances/triplefox4.0/src/plone.app.locales'
warning: no files found matching '*.mo' anywhere in distribution
Develop: '/home/goa/instances/triplefox4.0/src/Products.Marshall'
Develop: '/home/goa/instances/triplefox4.0/src/plone.app.form'
Develop: '/home/goa/instances/triplefox4.0/src/ 
Products.ResourceRegistries'
Develop: '/home/goa/instances/triplefox4.0/src/plone.app.jquerytools'
Develop: '/home/goa/instances/triplefox4.0/src/Products.ATContentTypes'
Develop: '/home/goa/instances/triplefox4.0/src/plone.stringinterp'
Develop: '/home/goa/instances/triplefox4.0/src/ 
archetypes.referencebrowserwidget'
Develop: '/home/goa/instances/triplefox4.0/src/Plone'
Develop: '/home/goa/instances/triplefox4.0/src/plone.app.portlets'
Develop: '/home/goa/instances/triplefox4.0/src/archetypes.kss'
Develop: '/home/goa/instances/triplefox4.0/src/plone.app.openid'
Develop: '/home/goa/instances/triplefox4.0/src/Products.CMFCalendar'
Develop: '/home/goa/instances/triplefox4.0/src/Products.PlonePAS'
Develop: '/home/goa/instances/triplefox4.0/src/ 
Products.ZopeVersionControl'
Develop: '/home/goa/instances/triplefox4.0/src/Products.PloneTestCase'
Develop: '/home/goa/instances/triplefox4.0/src/ 
Products.PluggableAuthService'
Develop: '/home/goa/instances/triplefox4.0/src/Products.CMFUid'
Develop: '/home/goa/instances/triplefox4.0/src/plone.app.vocabularies'
Develop: '/home/goa/instances/triplefox4.0/src/Products.CMFActionIcons'
Develop: '/home/goa/instances/triplefox4.0/src/plone.app.layout'
Develop: '/home/goa/instances/triplefox4.0/src/borg.localrole'
Develop: '/home/goa/instances/triplefox4.0/src/kss.core'
Develop: '/home/goa/instances/triplefox4.0/src/plone.protect'
Develop: '/home/goa/instances/triplefox4.0/src/plone.session'
Develop: '/home/goa/instances/triplefox4.0/src/ 
Products.CMFPlacefulWorkflow'
Develop: '/home/goa/instances/triplefox4.0/src/Products.CMFCore'
Installing 'zc.recipe.egg'.
We have the distribution that satisfies 'zc.recipe.egg==1.2.2'.
Installing 'plone.recipe.zope2instance'.
We have a develop egg: plone.recipe.zope2instance 4.0dev
Getting required 'Zope2==2.12.0'
We have no distributions for Zope2 that satisfies 'Zope2==2.12.0'.
Getting distribution for 'Zope2==2.12.0'.
We have the distribution that satisfies 'setuptools==0.6c9'.
Running easy_install:
/home/goa/instances/triplefox4.0/env/bin/python2.6 "-c" "from  
setuptools.command.easy_install import main; main()" "-mUNxd" "/home/ 
goa/instances/triplefox4.0/eggs/tmpH8MNmV" "-q" "/tmp/ 
tmp7OOSvBget_dist/Zope2-2.12.0.tar.gz"
path=/home/goa/instances/triplefox4.0/eggs/setuptools-0.6c9-py2.6.egg

Traceback (most recent call last):
   File "<string>", line 1, in <module>
   File "/home/goa/instances/triplefox4.0/env/lib/python2.6/site- 
packages/setuptools-0.6c9-py2.6.egg/setuptools/command/ 
easy_install.py", line 1671, in main
   File "/home/goa/instances/triplefox4.0/env/lib/python2.6/site- 
packages/setuptools-0.6c9-py2.6.egg/setuptools/command/ 
easy_install.py", line 1659, in with_ei_usage
   File "/home/goa/instances/triplefox4.0/env/lib/python2.6/site- 
packages/setuptools-0.6c9-py2.6.egg/setuptools/command/ 
easy_install.py", line 1675, in <lambda>
   File "/usr/local/lib/python2.6/distutils/core.py", line 152, in setup
     dist.run_commands()
   File "/usr/local/lib/python2.6/distutils/dist.py", line 975, in  
run_commands
     self.run_command(cmd)
   File "/usr/local/lib/python2.6/distutils/dist.py", line 995, in  
run_command
     cmd_obj.run()
   File "/home/goa/instances/triplefox4.0/env/lib/python2.6/site- 
packages/setuptools-0.6c9-py2.6.egg/setuptools/command/ 
easy_install.py", line 211, in run
   File "/home/goa/instances/triplefox4.0/env/lib/python2.6/site- 
packages/setuptools-0.6c9-py2.6.egg/setuptools/command/ 
easy_install.py", line 427, in easy_install
   File "/home/goa/instances/triplefox4.0/env/lib/python2.6/site- 
packages/setuptools-0.6c9-py2.6.egg/setuptools/command/ 
easy_install.py", line 476, in install_item
   File "/home/goa/instances/triplefox4.0/env/lib/python2.6/site- 
packages/setuptools-0.6c9-py2.6.egg/setuptools/command/ 
easy_install.py", line 655, in install_eggs
   File "/home/goa/instances/triplefox4.0/env/lib/python2.6/site- 
packages/setuptools-0.6c9-py2.6.egg/setuptools/command/ 
easy_install.py", line 930, in build_and_install
   File "/home/goa/instances/triplefox4.0/env/lib/python2.6/site- 
packages/setuptools-0.6c9-py2.6.egg/setuptools/command/ 
easy_install.py", line 919, in run_setup
   File "/home/goa/instances/triplefox4.0/env/lib/python2.6/site- 
packages/setuptools-0.6c9-py2.6.egg/setuptools/sandbox.py", line 27,  
in run_setup
   File "/home/goa/instances/triplefox4.0/env/lib/python2.6/site- 
packages/setuptools-0.6c9-py2.6.egg/setuptools/sandbox.py", line 63,  
in run
   File "/home/goa/instances/triplefox4.0/env/lib/python2.6/site- 
packages/setuptools-0.6c9-py2.6.egg/setuptools/sandbox.py", line 29,  
in <lambda>
   File "setup.py", line 153, in <module>
   File "/usr/local/lib/python2.6/distutils/core.py", line 152, in setup
     dist.run_commands()
   File "/usr/local/lib/python2.6/distutils/dist.py", line 975, in  
run_commands
     self.run_command(cmd)
   File "/usr/local/lib/python2.6/distutils/dist.py", line 995, in  
run_command
     cmd_obj.run()
   File "/home/goa/instances/triplefox4.0/env/lib/python2.6/site- 
packages/setuptools-0.6c9-py2.6.egg/setuptools/command/bdist_egg.py",  
line 174, in run
   File "/home/goa/instances/triplefox4.0/env/lib/python2.6/site- 
packages/setuptools-0.6c9-py2.6.egg/setuptools/command/bdist_egg.py",  
line 161, in call_command
   File "/usr/local/lib/python2.6/distutils/cmd.py", line 333, in  
run_command
     self.distribution.run_command(command)
   File "/usr/local/lib/python2.6/distutils/dist.py", line 995, in  
run_command
     cmd_obj.run()
   File "/home/goa/instances/triplefox4.0/env/lib/python2.6/site- 
packages/setuptools-0.6c9-py2.6.egg/setuptools/command/ 
install_lib.py", line 20, in run
   File "/usr/local/lib/python2.6/distutils/command/install_lib.py",  
line 113, in build
     self.run_command('build_ext')
   File "/usr/local/lib/python2.6/distutils/cmd.py", line 333, in  
run_command
     self.distribution.run_command(command)
   File "/usr/local/lib/python2.6/distutils/dist.py", line 995, in  
run_command
     cmd_obj.run()
   File "/home/goa/instances/triplefox4.0/env/lib/python2.6/site- 
packages/setuptools-0.6c9-py2.6.egg/setuptools/command/build_ext.py",  
line 46, in run
   File "/usr/local/lib/python2.6/distutils/command/build_ext.py",  
line 340, in run
     self.build_extensions()
   File "/usr/local/lib/python2.6/distutils/command/build_ext.py",  
line 449, in build_extensions
     self.build_extension(ext)
   File "/home/goa/instances/triplefox4.0/env/lib/python2.6/site- 
packages/setuptools-0.6c9-py2.6.egg/setuptools/command/build_ext.py",  
line 175, in build_extension
   File "/usr/local/lib/python2.6/distutils/command/build_ext.py",  
line 460, in build_extension
     ext_path = self.get_ext_fullpath(ext.name)
   File "/usr/local/lib/python2.6/distutils/command/build_ext.py",  
line 633, in get_ext_fullpath
     filename = self.get_ext_filename(modpath[-1])
   File "/home/goa/instances/triplefox4.0/env/lib/python2.6/site- 
packages/setuptools-0.6c9-py2.6.egg/setuptools/command/build_ext.py",  
line 85, in get_ext_filename
KeyError: 'cAccessControl'
An error occured when trying to install Zope2 2.12.0.Look above this  
message for any errors thatwere output by easy_install.
While:
   Installing.
   Getting section instance.
   Initializing section instance.
   Installing recipe plone.recipe.zope2instance.
   Getting distribution for 'Zope2==2.12.0'.
Error: Couldn't install: Zope2 2.12.0
*************** PICKED VERSIONS ****************
[versions]

*************** /PICKED VERSIONS ***************

--
Armin Carl Stroß-Radschinski, Dipl. Designer
acsr industrialdesign, Landgrafenstraße 32, 53842 Troisdorf, Germany

Telefon +49 (0) 22 41 / 94 69 94, FAX +49 (0) 22 41 / 94 69 96
eMail developer at acsr.de - http://www.acsr.de

UST. ID Nr: DE154092803







More information about the Setup mailing list