[Setup] Re: buildouts failing trying to apply a security patch

Maurits van Rees m.van.rees at zestsoftware.nl
Thu May 7 10:08:39 UTC 2009


francoise, on 2009-05-07:
>
> Hello,
>
> I'm having troubles trying to ugrade PlonePas to 3.9 on a Plone 3.2.2 as
> describe here :
> http://plone.org/products/plone/security/advisories/cve-2009-0662#for-plone-3-2
>
> I have had no problem with openid
>
> I'm not using buildout without -n
>
> Here is the error I get :
>
> ...
> Updating zope2.
> Updating fake eggs
> Updating productdistros.
> Updating instance.
> Getting distribution for 'Products.PlonePAS==3.9'.
> error: Not a recognized archive type:
> /.../Plone-3.2.2/buildout-cache/downloads/dist/Products.PlonePAS-3.9.zip
> An error occured when trying to install Products.PlonePAS 3.9.Look above
> this message for any errors thatwere output by easy_install.

This tells you the error: that zip file is not a recognized archive
type.  Strange, but maybe googling for that error points you
somewhere.

Some ideas:

I would say: remove that zip file and run bin/buildout again to see if
that fixes it.  Or first check if that file is empty: the download may
have failed initially.  Maybe download it manually, and check if you
can manually unzip it to see if the download was successfull.

-- 
Maurits van Rees | http://maurits.vanrees.org/
            Work | http://zestsoftware.nl/
"This is your day, don't let them take it away." [Barlow Girl]




More information about the Setup mailing list