[Setup] Windows Active Directory Authentication Problem

cvielma cvielma+nable at gmail.com
Thu Mar 12 14:06:49 UTC 2009

johnfugazi wrote:
> what does your "Active Directory Multi Plugin" config look like? 


Thank you for your quick response. I expended two days in this until i ask
to the list. And yesterday in the last 10 minutes of the day i choosed to
create a new plone site and started again (there isn't a big deal because i
had an extension profile to config the initials things and i'm just starting
building the system). I don't know what happened before but i don't have any
problem now. I even writed every step i followed and i repeated it and this
time that worked. 

I think my first mistake was that (because i don't have access to the AD's
admin account) i didn't put any user in the field Manager DN. Then when i
putted my user there it didn't worked. Then started over and over again the
process (deleting the config and creating it again) instead of using the
undo tool of the ZMI.

And i hope i'm no wrong but i think that step 3 of this
(that is, deleting and creating the credentials_cookie_auth) affected the
configuration in a bad way. At least in my system.

So the problem is solved, thank you again for your response. Still, i send
the configuration of the multiplugin

- Active Funcionality: Authentication, Properties, User_enumeration
- AD config (fields replaced for security reasons):

Login Name Attribute 	windows login name
User ID Attribute 	windows login name
RDN Attribute 	cn
Users Base DN 	dc=MYDOMAIN,dc=COM	Scope subtree
Group storage 	on ldap
Group mapping (Applies to LDAP group storage only) 	manually map
Groups Base DN dc=MYDOMAIN,dc=COM			Scope 	subtree
Manager DN ANYUSER at MYDOMAIN.COM		Password 	**********
Manager DN Usage always		Read-only 	si
User object classes 	top,person
User password encryption 	sha
Default User Roles 	Anonymous

- In the plugins section changed the order of some plugins execution:
Authentication Plugins   	 ACM AD source_users session
Properties Plugins   	 ACM AD mutable_properties
User_Enumeration Plugins   	 ACM AD source_users mutable_properties

That's what you asked? 

That's all i did and it worked. 
View this message in context: http://n2.nabble.com/Windows-Active-Directory-Authentication-Problem-tp2463837p2467510.html
Sent from the Installation, Setup, Upgrades mailing list archive at Nabble.com.

More information about the Setup mailing list