[Setup] Windows Active Directory Authentication Problem

cvielma cvielma+nable at gmail.com
Wed Mar 11 21:07:24 UTC 2009


Hi there!

I'm new with Plone, and i'm going to make an Intranet/Knowledge Management
System based on Plone to an medium-size consulting enterprise.

I have the following issue:
I have to allow users to login to Windows Active Directory and i can't. I
have installed PloneLDAP and all the stuff that comes with it. I can access
trought ZMI and configure an Active Directory Multi Plugin and even browse
users through  the users tab in
/acmkms/acl_users/MY_ACTIVE_DIRECTORY/acl_users. 

I also can browse users through the User tab in Plone itself. But i can't
login with any user in the AD. Plone keeps saying:

Error
    Login failed. Both login name and password are case sensitive, check
that caps lock is not enabled. 


I have the following configuration:
Zope: 2.10.6-final
Python: 2.4.5 
Ubuntu: 8.04
Plone: 3.2.1

I have done the following:
- Installed Plone from buildout (using the guidelines from the Plone
documentation and the Professional Plone Development book).
- For the AD authentication i have consulted (besides the book):
   
http://plone.org/documentation/how-to/large-activedirectory-authentication/active-directory-authentication
   
http://plone.org/documentation/how-to/authenticating-users-with-active-directory-plone-3-x
   
http://plone.org/documentation/how-to/authenticating-with-active-directory
(THIS ALLOWED ME TO BROWSE USERS IN AD)
    http://plone.org/products/ploneldap (FOLLOWED SOME CONFIGURATIONS FROM
HERE)
   
http://plone.org/documentation/how-to/single-sign-on-with-active-directory
    
- I have also reviewed some forums, among them:
    http://plone.org/support/forums/setup#nabble-td351589 (THE SAME PROBLEM
ALSO HAPPEN TO ME WHEN I TRY TO LOGIN WITH A ACCOUNT THAT ISN'T AN AD'S
ACCOUNT, BUT THE SOLUTION DOESN'T WORK FOR ME)
    http://plone.org/support/forums/general#nabble-td2351347

Have'nt...
- Install simplon.plone.ldap (i could'nt), but i think this doesn't have
nothing to do with.
- Find in the plugins section (ZMI) how the AD plugin available to put in
users_management_plugins as it's supossed to be.

Sorry for the large post and my English (i'm from Venezuela). 

I hope you can help me.

Thank you!!!
-- 
View this message in context: http://n2.nabble.com/Windows-Active-Directory-Authentication-Problem-tp2463832p2463832.html
Sent from the Installation, Setup, Upgrades mailing list archive at Nabble.com.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.plone.org/pipermail/setup/attachments/20090311/8509f76e/attachment.htm


More information about the Setup mailing list