[Setup] Varnish cache does not appear to speed up page delivery

JimL jim.leek at eng.ox.ac.uk
Wed Mar 4 14:17:10 UTC 2009


Hi Ric,


Ricardo Newbery-2 wrote:
> 
> 
> Personally, I would examine response headers first before diving into  
> varnish stats and logs.  Both CacheFu and Varnish will add headers to  
> the response telling you what it's doing, whether it's getting the  
> content from cache or whether it's pulling it from the backend.  This  
> is usually all you need to know to diagnose 95% of cache issues.
> 
> 

Response headers are:

http://webstar.eng.ox.ac.uk:8000/IBME/IBME

GET /IBME/IBME HTTP/1.1
Host: webstar.eng.ox.ac.uk:8000
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.6)
Gecko/2009011913 Firefox/3.0.6 (.NET CLR 3.5.30729)
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en-gb,en;q=0.5
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive
Referer: http://webstar.eng.ox.ac.uk:8000/IBME/IBME
Cookie: __utmz=####
If-None-Match: ||IBME-MainTheme|en-gb;en;q=0.5|1|6509||||343382

HTTP/1.x 304 Not Modified
Server: Zope/(Zope 2.10.7-final, python 2.4.5, linux2) ZServer/1.1
Plone/3.2.1
Expires: Sun, 07 Mar 1999 14:10:14 GMT
Vary: Accept-Encoding
Etag: ||IBME-MainTheme|en-gb;en;q=0.5|1|6509||||343382
X-Caching-Rule-Id: plone-content-types
Cache-Control: max-age=0, s-maxage=0, private, must-revalidate
X-Header-Set-Id: cache-in-memory
Content-Length: 0
Date: Wed, 04 Mar 2009 14:10:14 GMT
X-Varnish: 1423877020
Age: 0
Via: 1.1 varnish
Connection: keep-alive
----------------------------------------------------------
http://webstar.eng.ox.ac.uk:8000/IBME/IBME/images/IBMEExterior.jpg/image_preview

GET /IBME/IBME/images/IBMEExterior.jpg/image_preview HTTP/1.1
Host: webstar.eng.ox.ac.uk:8000
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.6)
Gecko/2009011913 Firefox/3.0.6 (.NET CLR 3.5.30729)
Accept: image/png,image/*;q=0.8,*/*;q=0.5
Accept-Language: en-gb,en;q=0.5
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive
Referer: http://webstar.eng.ox.ac.uk:8000/IBME/IBME
Cookie: __utmz=####
If-Modified-Since: Thu, 19 Feb 2009 15:34:52 GMT

HTTP/1.x 304 Not Modified
Date: Wed, 04 Mar 2009 14:10:14 GMT
Via: 1.1 varnish
X-Varnish: 1423877021
Last-Modified: Thu, 19 Feb 2009 15:34:52 GMT
Connection: keep-alive
----------------------------------------------------------

>From this I assume that Varnish is indeed caching.

Still, slower performance than I'd expect.

Cheers,  Jim

-- 
View this message in context: http://n2.nabble.com/Varnish-cache-does-not-appear-to-speed-up-page-delivery-tp2422346p2423034.html
Sent from the Installation, Setup, Upgrades mailing list archive at Nabble.com.




More information about the Setup mailing list