[Setup] Re: Setup Digest, Vol 40, Issue 28

Nick Davis nd51 at leicester.ac.uk
Fri Feb 27 15:51:11 UTC 2009


Goran,
   From what you say, it sounds like you don't have any 3rd-party 
products installed right now. Also your customisations sound fairly 
minimal so unlikely to be a problem. In other words, your site is fairly 
standard, so its difficult to see why its having these problems.
   The traceback indicates that it blew up trying to install CMFDiffTool.
It looks like the quickinstaller has got messed up somehow.
   Have you definitely never previously installed any other 3rd-party 
products? Sometimes these can mess up a site.
   Sorry but I don't know enough to help you further. :-( Maybe someone 
else can comment?
Regards,
Nick

Goran Sljivic wrote:
> 
>>    1. Re: Problem migration Plone 2.5.1 to 3.03 (Nick Davis)
>>
>>
>> ----------------------------------------------------------------------
>>
>> Message: 1
>> Date: Fri, 27 Feb 2009 10:38:50 +0000
>> From: Nick Davis <nd51 at leicester.ac.uk>

> 2009-02-27T13:41:33 INFO Plone  
> Attempting to upgrade from: 2.5.4-2
> ------
> 2009-02-27T13:41:33 ERROR Plone  
> Upgrade aborted
> ------
> 2009-02-27T13:41:33 ERROR Plone  
> Error type: exceptions.TypeError
> ------
> 2009-02-27T13:41:33 ERROR Plone  
> Error value: 'NoneType' object is not callable
> ------
> 2009-02-27T13:41:33 ERROR Plone  
>   File "C:\Program Files\Plone 3\Data\Products\CMFPlone\MigrationTool.py", line 210, in upgrade
>     newv, msgs = self._upgrade(newv)
> 
> ------
> 2009-02-27T13:41:33 ERROR Plone  
>   File "C:\Program Files\Plone 3\Data\Products\CMFPlone\MigrationTool.py", line 321, in _upgrade
>     res = function(self.aq_parent)
> 
> ------
> 2009-02-27T13:41:33 ERROR Plone  
>   File "C:\Program Files\Plone 3\Data\Products\CMFPlone\migrations\v3_0\alphas.py", line 123, in three0_alpha1
>     installProduct('CMFDiffTool', portal, out, hidden=True)
> 
> ------
> 2009-02-27T13:41:33 ERROR Plone  
>   File "C:\Program Files\Plone 3\Data\Products\CMFPlone\migrations\v3_0\alphas.py", line 616, in installProduct
>     installOrReinstallProduct(portal, product, out, hidden=hidden)
> 
> ------

-- 
Nick Davis
Web Application Developer
University of Leicester
http://www2.le.ac.uk




More information about the Setup mailing list