[Setup] Re: Plone 3.2.1 installation error -- Failed to create virtual environment for /usr/local/bin/python

Vijay Sankar vsankar2005 at gmail.com
Wed Feb 11 14:51:12 UTC 2009


I went through the install.sh script and redefining PY before

if [ ! -x "$PY" ]; then
         echo "\nFailed to create virtual environment for $WITH_PYTHON"
        exit 1
fi

solved the problem. Plone 3.2.1 is now working very nicely on OpenBSD 4.4
-stable and also tested it successfully on OpenBSD 4.5 -beta.

Thank you for a great product and for the new setup scripts.


On Wed, Feb 11, 2009 at 7:08 AM, Vijay Sankar <vsankar2005 at gmail.com> wrote:

> I am trying to install Plone 3.2.1 using setup tools on a non-root account
> as follows but the installation fails with the error
>
> "Failed to create virtual environment for /usr/local/bin/python"
>
> $ ./install.sh standalone --with-python=/usr/local/bin/python
> Stand-Alone Zope Instance selected
>
> Detailed installation log being written to
> /home/vsankar/Plone-3.2.1-UnifiedInstaller/install.log
>
>
> Testing /usr/local/bin/python for Zope/Plone requirements....
> /usr/local/bin/python looks OK. We'll try to use it.
>
> Rootless install method chosen. Will install for use by system user vsankar
>
> Installing Plone 3.2.1 at /home/vsankar/Plone
>
> Creating python virtual environment...
> New python executable in /home/vsankar/Plone/Python-2.4/bin/python
> Installing setuptools..............done.
>
> Failed to create virtual environment for /usr/local/bin/python
>
> I installed virtualenv using easy_install but that did not make any
> difference.
>
> I am using OpenBSD 4.4 and the following packages are already installed:
>
> py-Imaging-1.1.5p2-python2.4 Python imaging library
> py-setuptools-0.6c8 simplified packaging system for Python modules
> python-2.4.4p7      interpreted object-oriented programming language
> python-expat-2.4.4p7 expat module for Python
> python-tkinter-2.4.4p7 tk GUI module for Python
> python-tools-2.4.4p7 extra tools for Python
>
> Is there anything else that should be installed as a pre-requisite. The
> README says that this should work with OpenBSD 4.2 and I tried that as well
> with the same results.
>
> Thanks very much,
>
> Vijay
>
> --
> Vijay Sankar
> vsankar2005 at gmail.com
>
>
>


-- 
Vijay Sankar
vsankar2005 at gmail.com
Phone: 204 885 9535
Home: 204 831 0007
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.plone.org/pipermail/setup/attachments/20090211/657a4d4b/attachment.htm


More information about the Setup mailing list