[Setup] Re: Upgrading from v3.2.3 to v3.3 : Requires 'zc.buildout>=1.2.0' error

Maurits van Rees m.van.rees at zestsoftware.nl
Thu Dec 31 16:48:19 UTC 2009


slok, on 2009-12-31:
>
> I am trying to upgrade Plone version v3.2.3 to v3.3 and encounter the
> following error after running bin/buildout
>
>==
> While:
>   Installing.
>   Getting section instance.
>   Initializing section instance.
>   Installing recipe plone.recipe.zope2instance.
> Error: There is a version conflict.
> We already have: zc.buildout 1.1.2
> but zc.recipe.egg 1.2.2 requires 'zc.buildout>=1.2.0'.
>==
>
> What causes this? And how do I solve this?

Try running buildout in newest mode: bin/buildout -nv

That tries to look for newer versions of packages if they are not
pinned.

If that does not help, look in your buildout.cfg and see if
zc.buildout is really pinned to version 1.1.2.  Change that to 1.2.0
(or the latest 1.4.3 should be fine too) and rerun bin/buildout -nv

-- 
Maurits van Rees | http://maurits.vanrees.org/
            Work | http://zestsoftware.nl/
"This is your day, don't let them take it away." [Barlow Girl]




More information about the Setup mailing list