[Setup] plone.app.ldap not installable in Kubuntu 9.10

Mirto Silvio Busico mirtosilvio.busico at fastwebnet.it
Thu Dec 10 15:54:20 UTC 2009


Hi all,

I'm using Kubuntu 9.10 (Karmic Koala) 64Bit.
Now I'm no more able to install (via buildout) plone.app.ldap

The problem seems to be that Kubuntu no more includes the openldap package.
Instead there is a libldap2-dev library that puts the include files in 
/usr/include

When I try to use the buildout it says that cannot find the openldap 
include files. It looks in /usr/local/openldap-2.3/include

Here the log:
...
Installing 
client1.                                                         
Getting distribution for 
'python-ldap>=2.0.6'.                              
extra_compile_args:                                                          

extra_objects:                                                               

include_dirs: /usr/local/openldap-2.3/include 
/usr/include/sasl             
library_dirs: 
/usr/local/openldap-2.3/lib                                   
libs: ldap_r lber sasl2 ssl 
crypto                                          
file Lib/ldap.py (for module ldap) not 
found                                
file Lib/ldap/schema.py (for module ldap.schema) not 
found                  
warning: no files found matching 
'Makefile'                                 
warning: no files found matching 
'Modules/LICENSE'                          
file Lib/ldap.py (for module ldap) not 
found                                
...

The question is: how can I change include_dirs and library_dirs used by 
the buildout?

Thanks
    Mirto


-------------- next part --------------
A non-text attachment was scrubbed...
Name: mirtosilvio_busico.vcf
Type: text/x-vcard
Size: 272 bytes
Desc: not available
Url : http://lists.plone.org/pipermail/setup/attachments/20091210/1761b8c6/mirtosilvio_busico.vcf


More information about the Setup mailing list