[Setup] Error while installing RichDocument

san82moon san82moon at gmail.com
Mon Sep 22 13:37:49 UTC 2008


hi,
thanks for your reply. i also found more detail in this post :
http://markmail.org/message/vi6werjcfxmy2gda#query:related%3Avi6werjcfxmy2gda+page:1+mid:vi6werjcfxmy2gda+state:results
Hope that helps someone else as well.... Now everything works fine.....  
:-D

Thank you,
Sunny




francoise wrote:
> 
> As I can not uninstall and install my policy product, I :
> 
> - keep a copy of buildout.cfg and policy.product somewhere in the file
> system
> - install again Plone with Unified installer 
> - put my buildout.cfg in the zinstance directory and policy product in the
> src directory
> - execute ./bin/buildout and install my policy product
> 
> This is heavy (but thanks to buildout not so much), and I should spend
> some time to write an uninstall() method to avoid this (if this is the
> problem).
> 
> 
> san82moon wrote:
>> 
>> hi,
>> i hav added the url 
>> urls =
>>    
>> http://plone.org/products/richdocument/releases/3.0.1/RichDocument-3.0.1.tar.gz
>> in buildout.cfg file of my buildout. n i hav followed all the steps
>> mentioned in the book. still i get the error. now i am not able to
>> install my policy product as well..... i tried by doing chap. 7 al over
>> again.... n i get same error....
>> 
>> 
>> 
>> francoise wrote:
>>> 
>>> I am following the same book
>>> 
>>> - add the product url to the [productdistros] section of buildout.cfg 
>>> urls =
>>>    
>>> http://plone.org/products/richdocument/releases/3.0.1/RichDocument-3.0.1.tar.gz
>>> - run /bin/buildout
>>> - create a Extensions directory in the policy product and create the
>>> Install.py file described on page 108-109
>>> - change the setuphandlers.py file according to the page 109
>>> 
>>> I had to uninstall the product and to install it again to get this
>>> worked
>>> 
>>> But now I cannot uninstall and install the policy product without having
>>> the kind of message you have posted
>>> 
>>> I think this is because we have no uninstall() method in Install.py
>>> 
>>> hope this can help you
>>> 
>>> 
>>> san82moon wrote:
>>>> 
>>>> hi,
>>>> i am getting this error when i try to install richdocument. am
>>>> following martin's book.
>>>> 
>>>> Traceback (innermost last):
>>>>   Module ZPublisher.Publish, line 119, in publish
>>>>   Module ZPublisher.mapply, line 88, in mapply
>>>>   Module ZPublisher.Publish, line 42, in call_object
>>>>   Module Products.CMFQuickInstallerTool.QuickInstallerTool, line 584,
>>>> in installProducts
>>>>   Module Products.CMFQuickInstallerTool.QuickInstallerTool, line 521,
>>>> in installProduct
>>>>    - __traceback_info__: ('SimpleAttachment',)
>>>>   Module Products.GenericSetup.tool, line 390, in
>>>> runAllImportStepsFromProfile
>>>>    - __traceback_info__:
>>>> profile-Products.SimpleAttachment:SimpleAttachment
>>>>   Module Products.GenericSetup.tool, line 1182, in
>>>> _runImportStepsFromContext
>>>>   Module Products.GenericSetup.tool, line 1093, in _doRunImportStep
>>>>    - __traceback_info__: simpleattachment
>>>>   Module Products.SimpleAttachment.setuphandlers, line 46, in
>>>> setupAttachments
>>>>   Module Products.kupu.plone.librarytool, line 240, in
>>>> updateResourceTypes
>>>>   Module Products.kupu.plone.librarytool, line 211, in
>>>> _validate_portal_types
>>>> KupuError: Resource type: linkable, invalid type: RichDocument
>>>>  
>>>> 
>>> 
>>> 
>> 
>> 
> 
> 

-- 
View this message in context: http://n2.nabble.com/Error-while-installing-RichDocument-tp1109203p1109630.html
Sent from the Installation, Setup, Upgrades mailing list archive at Nabble.com.




More information about the Setup mailing list