[Setup] Re: AttributeError: @@plone - Plone 2.5.3

Alexander Limi limi at plone.org
Sun Sep 7 01:02:14 UTC 2008


You didn't tell us whether you went to the ZMI and ran the  
portal_migration upgrade script. :)

On Fri, 05 Sep 2008 08:24:18 -0700, floseries  
<fritz at loseries.info> wrote:

>
> Hi,
>
> I've got a serious problem after I tried to upgrade Plone from 2.5.3 to
> 3.1.5
> Although afterwards I made a reinstallation to 2.5.3 the problem remains.
>
> I'm running Plone 2.5.3 under WINDOWS 2000 Home for experimental and
> development usage.
>
> Following traceback error I received, but I'm hopelessly lossed  
> concerning
> the meaning of @@plone and the reason of the error.
> For complete reporting I've to mention that I sent before all these a bug
> report to the plone trac system: http://dev.plone.org/plone/ticket/8449
> (here are also all version details of the programs and products  
> mentioned)
> After that I followed the recommendation to reindex the uid_catalog,  
> where
> first I have added the path index. Though maybe my problems can result  
> also
> from this. But in the whole, the problem remains and I don't know a
> solution.
>
> Traceback:
>     *  Module ZPublisher.Publish, line 196, in publish_module_standard
>     * Module Products.PlacelessTranslationService.PatchStringIO, line  
> 34, in
> new_publish
>     * Module ZPublisher.Publish, line 146, in publish
>     * Module Zope2.App.startup, line 243, in __call__
>     * Module ZPublisher.Publish, line 115, in publish
>     * Module ZPublisher.mapply, line 88, in mapply
>     * Module ZPublisher.Publish, line 41, in call_object
>     * Module Shared.DC.Scripts.Bindings, line 311, in __call__
>     * Module Shared.DC.Scripts.Bindings, line 348, in _bindAndExec
>     * Module Products.PageTemplates.ZopePageTemplate, line 255, in _exec
>     * Module Products.PageTemplates.PageTemplate, line 104, in pt_render
>    * Module TAL.TALInterpreter, line 238, in __call__
>     * Module TAL.TALInterpreter, line 281, in interpret
>     * Module TAL.TALInterpreter, line 749, in do_useMacro
>     * Module TAL.TALInterpreter, line 281, in interpret
>     * Module TAL.TALInterpreter, line 457, in do_optTag_tal
>     * Module TAL.TALInterpreter, line 442, in do_optTag
>     * Module TAL.TALInterpreter, line 437, in no_tag
>     * Module TAL.TALInterpreter, line 281, in interpret
>     * Module TAL.TALInterpreter, line 749, in do_useMacro
>     * Module TAL.TALInterpreter, line 281, in interpret
>     * Module TAL.TALInterpreter, line 511, in do_setGlobal_tal
>     * Module Products.PageTemplates.TALES, line 221, in evaluate
>       URL: file:CMFPlone/skins/plone_templates/global_defines.pt
>       Line 3, Column 0
>       Expression: standard:'context/@@plone'
>       Names:
>
>       {'container': ,
>        'context': ,
>        'default': ,
>        'here': ,
>        'loop': ,
>        'modules': ,
>        'nothing': None,
>        'options': {'args': ()},
>        'repeat': ,
>        'request': ,
>        'root': ,
>        'template': ,
>        'traverse_subpath': [],
>        'user': }
>
>     * Module Products.PageTemplates.Expressions, line 185, in __call__
>     * Module Products.PageTemplates.Expressions, line 173, in _eval
>     * Module Products.PageTemplates.Expressions, line 127, in _eval
>       __traceback_info__: context
>     * Module Products.PageTemplates.Expressions, line 286, in
> restrictedTraverse
>       __traceback_info__: {'path': ['@@plone'],  
> 'TraversalRequestNameStack':
> []}
>     * Module Products.Archetypes.BaseObject, line 1140, in  
> __bobo_traverse__
>
> AttributeError: @@plone (Also, the following error occurred while  
> attempting
> to render the standard error message, please see the event log for full
> details: @@plone)
>
>



-- 
Alexander Limi · http://limi.net




More information about the Setup mailing list