[Setup] Problem migrating from Plone 2.05 to 3.1.7 (resent)

aprati pratiandrea at gmail.com
Sat Nov 22 19:02:35 UTC 2008


Hi Steve,
thanks for your answer. Anyway, I don't know how to migrate from Plone 2.0.5
to newer versions.

My procedure is as follows:
1) install Plone 2.0.5
2) copy old Data.fs on Data/var folder
3) open ZMI

To start migration as you proposed (through portal_migration in ZMI) I at
least need to start ZMI, while in my case it does not work. Once copied old
Data.fs (step 2) there's no way to open Plone or Zope and act in any way.
Also installing newer version on step 1 did not solve the problem.

That's the reason I tought the file was corrupted (but I may be wrong).

Any suggestion?

Thanks
Andrea


Steve McMahon wrote:
> 
> An error on global_defines does *not* indicate corruption in your
> ZODB. In fact, it indicates that you're able to read the ZODB -- or
> you'd get a very different error.
> 
> The migration of data in the object database is done via
> portal_migrations in the ZMI. The procedure is documented at:
> 
> http://plone.org/documentation/manual/upgrade-guide/view?searchterm=migration
> 
> Migrating from 2.05 all the way to 3.x is going to be real work. Be
> patient and ask the community for advice. The plone.org/documentation
> help center and plone-users list are probably your best community
> resources.
> 
> 
> 
> On Fri, Nov 21, 2008 at 10:50 PM, aprati <pratiandrea at gmail.com> wrote:
>>
>> Hi there,
>> I'm really in trouble, pls help. I've recently updated a very old (but
>> often
>> used) site in which Plone 2.0.5 had been installed. Data.fs file was 2.5
>> GB!
>>
>> Anyway, I finally decided to update Plone to the latest version, but I
>> was
>> not aware of the correct procedure, so I installed the 3.1.7 by using the
>> Windows installer (the PC has Windows Server 2003). The problem is that
>> the
>> plone 3.1.7 cannot read the Data.fs. It gave me an error on
>> global_defines.
>> I spent some time in trying to understand what I need to change to get it
>> working. At the end, I decided to roll back to Plone 2.0.5... BUT IT DOES
>> NOT WORK ANYMORE. It seems as the Data.fs has been corrupted.
>>
>> After installing back Plone 2.0.5 I simply copied the 2.5 GB Data.fs file
>> to
>> overwrite the installed Data.fs on PLONE/Data/var. Am I wrong?
>> Can anyone help me and let me know how I can recover the Data.fs file
>> and/or
>> import it in whichever version of Plone???
>>
>> Thank you very much
>> Andrea
>> --
>> View this message in context:
>> http://n2.nabble.com/Problem-migrating-from-Plone-2.05-to-3.1.7-%28resent%29-tp1564864p1564864.html
>> Sent from the Installation, Setup, Upgrades mailing list archive at
>> Nabble.com.
>>
>>
>> _______________________________________________
>> Setup mailing list
>> Setup at lists.plone.org
>> http://lists.plone.org/mailman/listinfo/setup
>>
> 
> 
> 
> -- 
> 
> Steve McMahon
> Reid-McMahon, LLC
> steve at reidmcmahon.com
> steve at dcn.org
> 
> _______________________________________________
> Setup mailing list
> Setup at lists.plone.org
> http://lists.plone.org/mailman/listinfo/setup
> 
> 

-- 
View this message in context: http://n2.nabble.com/Problem-migrating-from-Plone-2.05-to-3.1.7-%28resent%29-tp1564864p1566190.html
Sent from the Installation, Setup, Upgrades mailing list archive at Nabble.com.




More information about the Setup mailing list