[Setup] Login problem after installation

John Hui john.hui at isolutions-eu.com
Sat Jun 21 11:11:31 UTC 2008


Hi,

I am a newbie to Plone.  I have searched the forum and did nto find any
answers.  I got this problem just after installation and I thought it is
probably linked to an installation problem.

I have just installed Plone 3.1.2 on a Windows XP platform.  It is up and
running.  I created a test user account and I managed to login at
http://localhost/.  But when I change localhost to 127.0.0.1, I still get
the same login page from Plone, but I can no longer login using the same
userid and password.  It keeps staying at the login page.  So I tried to
"retrieve my lost password" by clicking on the link provided.  After
entering the userid, it generated an error.

I checked out the error messages by logging in at localhost (instead of
127.0.0.1) and I get this traceback message. :confused:

Request URL 
   http://127.0.0.1/mail_password 
Exception Type 
   KeyError 
Exception Value 
   'userid' 


Traceback (innermost last):
  Module ZPublisher.Publish, line 119, in publish
  Module ZPublisher.mapply, line 88, in mapply
  Module ZPublisher.Publish, line 42, in call_object
  Module Products.CMFCore.FSPythonScript, line 140, in __call__
  Module Shared.DC.Scripts.Bindings, line 313, in __call__
  Module Shared.DC.Scripts.Bindings, line 350, in _bindAndExec
  Module Products.CMFCore.FSPythonScript, line 196, in _exec
  Module None, line 4, in mail_password
   - 
   - Line 4
  Module AccessControl.ZopeGuards, line 67, in guarded_getitem
  Module ZPublisher.HTTPRequest, line 1224, in __getitem__
KeyError: 'userid'



Can anyone figure out what is wrong with my installation or setup?


Thanks for any pointers.

John

-- 
View this message in context: http://www.nabble.com/Login-problem-after-installation-tp18025994s15482p18025994.html
Sent from the Installation, Setup, Upgrades mailing list archive at Nabble.com.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.plone.org/pipermail/setup/attachments/20080621/fa7a0ae5/attachment.htm


More information about the Setup mailing list