[Setup] TextIndexNG3 installation mystery

albieback alberto at alopes.com
Mon Jun 16 06:47:48 UTC 2008

Dear fellas,

I am using Plone 3.1.2 in Ubuntu. Installed with Unified Installer, and
added products only with buildout.

I am having problems in installing TextIndexNG3.

First I tried to install it like this (these are instructions from Zopyx

eggs =
recipe = plone.recipe.distros
urls =

Here, the problem is that that URL is invalid. I went to their sourceforge
area and, despite 3.2.5 being the "current release" (as said in their site),
I found only the 3.2.2.tar.gz file. I changed buildout.cfg and run buildout,
but TextIndexNG3 does not appear in Plone as a new product.

Then, I tried the second install method, commenting out the changes made

eggs = ...

zcml = ...

Here, I got a lot of warnings in my console while running buildout, but Zope
started. Then, when I tried to go to my Plone page, I got only this error

Site Error
An error was encountered while publishing this resource. 


('Could not adapt', , ) (Also, the following error occurred while attempting
to render the standard error message, please see the event log for full
details: ('Could not adapt', <CacheTool at /Plone/portal_cache_settings used
for /Plone/default_error_message>, <InterfaceClass
Products.Archetypes.interfaces._schema.ISchema>))Traceback (innermost last):
Module ZPublisher.Publish, line 202, in publish_module_standard Module
ZPublisher.Publish, line 150, in publish Module Zope2.App.startup, line 221,
in zpublisher_exception_hook Module ZPublisher.Publish, line 119, in publish
Module ZPublisher.mapply, line 88, in mapply Module ZPublisher.Publish, line
42, in call_object Module Shared.DC.Scripts.Bindings, line 313, in __call__
Module Shared.DC.Scripts.Bindings, line 350, in _bindAndExec Module
Products.CMFCore.FSPageTemplate, line 216, in _exec Module
Products.CacheSetup.patch_cmf, line 27, in FSPT_pt_render Module
Products.CacheSetup.content.cache_tool, line 281, in getEnabled Module
Products.Archetypes.BaseObject, line 241, in getField Module
Products.Archetypes.BaseObject, line 828, in Schema TypeError: (see above) 

I tried to go to ZMI main page, to check with Zope /error_log what happened.
ZMI opened okay, but when I clicked on /error_log, I got this error message
in its frame:

Error Type: TraversalError
Error Value: ('No traversable adapter found', {'ignored_exceptions':
('Unauthorized', 'NotFound', 'Redirect'), 'keep_entries': 20,
'copy_to_zlog': True})

If I comment out the TextIndexNG3 installation lines in buildout.cfg and run
buildout again, I can browse again to my site.

Does anyone have any idea on what happened and how I could solve it?



View this message in context: http://www.nabble.com/TextIndexNG3-installation-mystery-tp17858792s15482p17858792.html
Sent from the Installation, Setup, Upgrades mailing list archive at Nabble.com.

More information about the Setup mailing list