[Setup] Re: No module named misc.lock_file

Holden Hao holdenhao at gmail.com
Thu Jun 12 15:32:18 UTC 2008


On Thu, Jun 12, 2008 at 9:02 PM, Holden Hao <holdenhao at gmail.com> wrote:

> I am using buildout (following the buildout tutorial at plone.org) to
> install Plone 2.5.5 on a Centos 5 server.  My buildout is able to download
> and set everything up.  However, I have problems in starting my primary
> instance.
>
> Running ./bin/primary fg results in an import error.  The system returned:
>
> ----------------------------------------------
> 2008-06-12 08:47:15 INFO Zope Set effective user to "plone"
> Traceback (most recent call last):
>   File "/root/src/plone-2.5.5/parts/zope2/lib/python/Zope2/Startup/run.py",
> line 56, in ?
>   File "/root/src/plone-2.5.5/parts/zope2/lib/python/Zope2/Startup/run.py",
> line 21, in run
>   File "/usr/lib/python2.4/site-packages/PIL/__init__.py", line 95, in
> prepare
>
>   File "/usr/lib/python2.4/site-packages/PIL/__init__.py", line 272, in
> makeLockFile
>
> ImportError: No module named misc.lock_file
> ---------------------------------------------
>

I have now resolved this issue.  I simply created another Plone buildout
project on a different directory and used the same buildout.cfg and
deployment.cfg.  For some reason this resolved the issue.

When I created my first buildout, I mistakenly executed a simple
'./bin/buildout -v' so  it used my default buildout.cfg.  It created a
development buildout  so I tried to correct this with ./bin/buildout -c
deployment.cfg.  This built the deployment config but I got the lock_file
error above when I tried to start an instance.  I guess, the initial build
botched some permissions or variables that made the deployment config fail.

Regards,


Holden Hao
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.plone.org/pipermail/setup/attachments/20080612/d5d7b116/attachment.html


More information about the Setup mailing list