[Setup] Buildout and PIL

JimL jim.leek at eng.ox.ac.uk
Wed Jul 30 09:15:55 UTC 2008


Hi,

I'm experiencing problems with PIL when I install Plone using buildout.

Despite having installed PIL, Plone can't seem to find it, and when I run
Plone the first time (using startcluster.sh) no Plone site is created.
Looking at firststart.log I see the following error:

Traceback (most recent call last):
  File "/misc/local/Plone/parts/zope2/lib/python/OFS/Application.py", line
709, in import_product
    product=__import__(pname, global_dict, global_dict, silly)
  File "/misc/local/Plone/parts/plone/ATContentTypes/__init__.py", line 64,
in ?
    import Products.ATContentTypes.content
  File "/misc/local/Plone/parts/plone/ATContentTypes/content/__init__.py",
line 26, in ?
    import Products.ATContentTypes.content.link
  File "/misc/local/Plone/parts/plone/ATContentTypes/content/link.py", line
39, in ?
    from Products.ATContentTypes.content.base import registerATCT
  File "/misc/local/Plone/parts/plone/ATContentTypes/content/base.py", line
63, in ?
    from Products.CMFPlone.PloneFolder import ReplaceableWrapper
  File "/misc/local/Plone/parts/plone/CMFPlone/__init__.py", line 215, in ?
    from browser import ploneview
  File "/misc/local/Plone/parts/plone/CMFPlone/browser/ploneview.py", line
12, in ?
    from Products.CMFPlone import utils
  File "/misc/local/Plone/parts/plone/CMFPlone/utils.py", line 5, in ?
    from PIL import Image
ImportError: No module named PIL

In addition to this, when I enter the ZMI, there is no "Plone site" under
the add menu.

INFO:
* Zope Version = (Zope 2.10.6-final, python 2.4.3, sunos5)
* Python Version = 2.4.3 (#1, Jul 31 2006, 06:30:48) [GCC 3.3.2]
* System Platform = sunos5 (Solaris 10 - sparc)
* SOFTWARE_HOME = /misc/local/Plone/parts/zope2/lib/python
* ZOPE_HOME = /misc/local/Plone/parts/zope2
* INSTANCE_HOME = /misc/local/Plone/parts/client1 

I have installed PIL from http://www.pythonware.com/products/pil/ and it is
at location:

/misc/local/lib/python2.4/site-packages/PIL

I did check Nabble before posting this, and the best suggestion was:
http://n2.nabble.com/No-%22Plone-Site%22-listed-under-Add-menu-in-Zope-tp351605p351607.html

However the suggestion to copy the folder "python24\Lib\site-packages\PIL"
to "Zope\2.X.X\Python\Lib\site-packages\" doesn't apply here as there is no
"Zope\2.X.X\Python\Lib\site-packages\" produced by my buildout.

I've even tried experimenting with adding a PIL.pth file into
/misc/local/Plone/parts/client1/lib/python referencing the real PIL path,
but not being a Python developer I really am stumbling around in the dark.

Can anyone help?

Cheers,  Jim
-- 
View this message in context: http://n2.nabble.com/Buildout-and-PIL-tp641973p641973.html
Sent from the Installation, Setup, Upgrades mailing list archive at Nabble.com.




More information about the Setup mailing list