[Setup] Product Five Problem after Upgrade

Hilde T Lauvset Rafaelsen hilde.rafaelsen at cc.uit.no
Fri Jul 11 11:27:54 UTC 2008

We have run Plone 2.5.3 and zope 2.9.8 on fedora6 for a long time, but
finaly we decided to upgrade to a newer version. Before I did the upgrade I
copied the database, the Products catalog, httpd.conf, and zope.conf to a
new server with the exact same version of plone, python, zope and apache.
This went fine.
I thought it was best to upgrade to plone 3.0.3 and zope 2.10.5 before I
upgrade to the newest version.
The upgrade went fine but know I have problems with starting zope. This
problem seems to be related to the product Five witch I have copied from the
old Plone 2.5 version.
If I run ./zopectl debug I get this message:
Starting debugger (the name "app" is bound to the top-level Zope object)
/var/lib/zope/Products/Five/browser/__init__.py:21: DeprecationWarning:
BrowserView is deprecated. It has been moved to zope.publisher.browser. This
reference will be removed in Zope 3.5.
  class BrowserView(Acquisition.Explicit,
Traceback (most recent call last):
  File "<string>", line 1, in ?
  File "/usr/lib/zope/lib/python/Zope2/__init__.py", line 51, in app
  File "/usr/lib/zope/lib/python/Zope2/__init__.py", line 46, in startup
    from Zope2.App.startup import startup as _startup
  File "/usr/lib/zope/lib/python/Zope2/App/startup.py", line 32, in ?
    import OFS.Application
  File "/usr/lib/zope/lib/python/OFS/Application.py", line 30, in ?
    from App.ApplicationManager import ApplicationManager
  File "/usr/lib/zope/lib/python/App/ApplicationManager.py", line 35, in ?
    from Products.PageTemplates.PageTemplateFile import PageTemplateFile
"/usr/lib/zope/lib/python/Products/PageTemplates/PageTemplateFile.py", line
26, in ?
    from Products.PageTemplates.Expressions import SecureModuleImporter
  File "/usr/lib/zope/lib/python/Products/PageTemplates/Expressions.py",
line 40, in ?
    from Products.Five.browser.providerexpression import
ImportError: No module named providerexpression

If I delete the Five catalog from Products I manage to start Zope. Zope seem
to work fine, but when I want to view my plone site I got a lot of errors. I
also got a lot of errors and warnings when i run zopectl debug.
I really hope someone can give me a hint of what to do :)
And does anybody know if it will work to just copy the database and not the
Product catalog from plone 2.5 to a newer plone version? 

More information about the Setup mailing list