[Setup] Re: Failed ZopeSkel install

Maurits van Rees m.van.rees at zestsoftware.nl
Sat Jul 5 23:27:50 UTC 2008


yude at cip.cu, on 2008-07-06:
> This is a multi-part message in MIME format.
> --------------010307090605080102010800
> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
> Content-Transfer-Encoding: 7bit
>
> Hello
>
> I am attempting a new install of Zope/Plone via the method in "Professional
> Plone Development". I made sure all the pre-requisites are in place but I am
> getting an error during the ZopeSkel install.  My Gcc is version 4.2.2
>
> The complete error message is in the attachment cause its very large
>
> I have seen this error in my searches, but no clean answers were listed, so I am asking for assistance.
>
> Thanks,
>
> Yudeisy
>
>
> --------------010307090605080102010800
> Content-Type: text/plain;
>  name="error"
> Content-Transfer-Encoding: 8bit
> Content-Disposition: inline;
>  filename="error"
>
>
> # easy_install ZopeSkel
> Searching for ZopeSkel
> Best match: ZopeSkel 2.3
> Processing ZopeSkel-2.3-py2.4.egg
> ZopeSkel 2.3 is already the active version in easy-install.pth
>
> Using /usr/lib/python2.4/site-packages/ZopeSkel-2.3-py2.4.egg
> Processing dependencies for ZopeSkel
> Searching for Cheetah
> Reading http://pypi.python.org/simple/Cheetah/
> Reading http://www.CheetahTemplate.org/
> Reading http://sourceforge.net/project/showfiles.php?group_id=28961
> Best match: Cheetah 2.0.1
> Downloading http://downloads.sourceforge.net/cheetahtemplate/Cheetah-2.0.1.tar.gz?download
> Processing Cheetah-2.0.1.tar.gz
> Running Cheetah-2.0.1/setup.py -q bdist_egg --dist-dir /tmp/easy_install-HJnatY/Cheetah-2.0.1/egg-dist-tmp-AAbBmC
> warning: no files found matching '*.cfg'
> warning: no files found matching 'examples'
> warning: no files found matching 'docs'
> warning: no files found matching 'bin'
> warning: no files found matching '*' under directory 'docs'
> warning: no files found matching '*' under directory 'examples'
> warning: no previously-included files matching '*.pyc' found under directory 'src'
> warning: no previously-included files matching '*~' found under directory 'src'
> warning: no previously-included files matching '*.aux' found under directory 'src'
> warning: no previously-included files matching '*~' found under directory 'docs'
> warning: no previously-included files matching '*.aux' found under directory 'docs'
> src/_namemapper.c:15:58: error: Python.h: No existe el fichero o el directorio

It looks like you are missing python development files.  If this is
Debian/Ubuntu you can do:

aptittude install python2.4-dev

Perhaps install some other development packages as well:

aptitude install build-essential 

-- 
Maurits van Rees | http://maurits.vanrees.org/
            Work | http://zestsoftware.nl/
"This is your day, don't let them take it away." [Barlow Girl]




More information about the Setup mailing list