[Setup] Failed Plone 3.1.2 install using Windows Installer

AK0 angelknight0 at hotmail.com
Thu Jul 3 16:57:47 UTC 2008


I've cleaned up the install every time, removing the folders, as well as
searching through the registry for any leftover pieces. I've rebooted and
done a second pass to catch any services, registry entries or files that may
have been locked that I didn't catch. I've also tried installing to an
alternate folder name, avoiding using spaces or other special characters in
the path name. I've tried older versions of the quick installer, but no luck
there either. 

>From other posts that describe similar errors, the answer has typically been
a second installation of python. However, I can't find anything in the
environment variables or registry that would hint at a second instance.

But thanks for the suggestion anyway.



afewtips wrote:
> 
> I'm pretty new to Plone - but - I have had my share of errors.
> First, you're using the quick installer for Windows? 
> You don't have to add a Plone Site with the installer, it is all taken
> care of during install, so the error you get when you try to add is the
> same process that the installer is probably doing as well.
> 
> The one thing I would mention is that after I have uninstalled the
> installation, I have always deleted the old Plone folder and made sure it
> was gone. Are you cleaning up everything after it doesn't install? 
> And I don't insatll into the default name - Plone 3 - Rather I install
> into Plone3 (No space).
> 
> I have installed the 3.1 versions many times on both Windows XP and Vista
> and haven't had any problems installing. 
> (All of my problems have been self inflicted). 
> Good luck - Hope this helps.
> 
> 
> AK0 wrote:
>> 
>> I've been trying to install Plone 3 to a Windows XP environment, but keep
>> encountering an error in the "Initializing Plone Site" step of the
>> install. The rest of the installation completes successfully and I'm able
>> to access the ZMI, but the default Plone site does not appear to have
>> been added. When I try to add a Plone Site product directly in the ZMI, I
>> encounter the same error message that popped up running the installer.
>> 
>> Error encountered running SiteSetup.py
>> Error Type: TypeError
>> Error Value: __init__() takes exactly 1 argument (2 given)
>> 
>> Similar posts in other forums have suggested removing AOL instant
>> messenger or other web servers that may be running, but I've never had
>> any of these installed. I've searched and removed all files and registry
>> entries that refer to python, apache or other potential offending apps,
>> but still no luck.
>> 
>> Below is the post-install log dump. Any suggestions on what I may be
>> missing would be greatly appreciated.
>> 
>> -------------------------------------
>> 06/26/08 15:22:18: 2936: ['C:\\Program Files\\Plone
>> 3\\Zope\\bin\\mkzopeinstance.py', '-d', 'C:\\Program Files\\Plone
>> 3\\Data', '-u', 'admin:acdeg99']
>> Wrote 'C:\\Program Files\\Plone 3\\Data\\.\\bin\\runzope.bat'
>> Wrote 'C:\\Program Files\\Plone 3\\Data\\.\\bin\\runzope'
>> Changed mode for C:\Program Files\Plone 3\Data\.\bin\runzope to 777
>> Wrote 'C:\\Program Files\\Plone 3\\Data\\.\\bin\\setenv.bat'
>> Wrote 'C:\\Program Files\\Plone 3\\Data\\.\\bin\\test.bat'
>> Wrote 'C:\\Program Files\\Plone 3\\Data\\.\\bin\\zopectl'
>> Changed mode for C:\Program Files\Plone 3\Data\.\bin\zopectl to 777
>> Wrote 'C:\\Program Files\\Plone 3\\Data\\.\\bin\\zopeservice.py'
>> Changed mode for C:\Program Files\Plone 3\Data\.\bin\zopeservice.py to
>> 777
>> Wrote 'C:\\Program Files\\Plone 3\\Data\\.\\etc\\plone.conf'
>> Wrote 'C:\\Program Files\\Plone 3\\Data\\.\\etc\\zope.conf'
>> Wrote 'C:\\Program Files\\Plone 3\\Data\\.\\lib\\python\\README.txt'
>> 06/26/08 15:22:18: 2936: finished
>> 06/26/08 15:22:19: 3188: ['C:\\Program Files\\Plone
>> 3\\Data\\bin\\zopeservice.py', '--startup', 'auto', 'install']
>> Installing service Zope_1313807186
>> Service installed
>> 06/26/08 15:22:23: 3188: finished
>> 06/26/08 15:22:23: 2872: ['C:\\Program Files\\Plone
>> 3\\Data\\Products\\CMFPlone\\Extensions\\setupSite.py', 'admin',
>> 'C:\\Program Files\\Plone 3\\Data', 'C:\\Program Files\\Plone 3\\Data']
>> C:\Program Files\Plone
>> 3\Zope\lib\python\zope\configuration\xmlconfig.py:323:
>> DeprecationWarning: zope.app.annotation has moved to zope.annotation.
>> Import of zope.app.annotation will become unsupported in Zope 3.5
>>   __import__(arguments[0])
>> C:\Program Files\Plone 3\Data\Products\GenericSetup\registry.py:744:
>> DeprecationWarning: Version for profile
>> Products.CMFActionIcons:actionicons taken from version.txt. This is
>> deprecated behaviour and will be removed in GenericSetup 1.5: please
>> specify the version in metadata.xml.
>>   DeprecationWarning)
>> C:\Program Files\Plone 3\Data\Products\GenericSetup\registry.py:744:
>> DeprecationWarning: Version for profile Products.CMFCalendar:default
>> taken from version.txt. This is deprecated behaviour and will be removed
>> in GenericSetup 1.5: please specify the version in metadata.xml.
>>   DeprecationWarning)
>> C:\Program Files\Plone 3\Data\Products\GenericSetup\registry.py:744:
>> DeprecationWarning: Version for profile
>> Products.CMFCalendar:skins_support taken from version.txt. This is
>> deprecated behaviour and will be removed in GenericSetup 1.5: please
>> specify the version in metadata.xml.
>>   DeprecationWarning)
>> C:\Program Files\Plone 3\Data\Products\GenericSetup\registry.py:744:
>> DeprecationWarning: Version for profile Products.CMFDefault:default taken
>> from version.txt. This is deprecated behaviour and will be removed in
>> GenericSetup 1.5: please specify the version in metadata.xml.
>>   DeprecationWarning)
>> C:\Program Files\Plone 3\Data\Products\GenericSetup\registry.py:744:
>> DeprecationWarning: Version for profile Products.CMFDefault:views_support
>> taken from version.txt. This is deprecated behaviour and will be removed
>> in GenericSetup 1.5: please specify the version in metadata.xml.
>>   DeprecationWarning)
>> C:\Program Files\Plone 3\Data\Products\GenericSetup\registry.py:744:
>> DeprecationWarning: Version for profile
>> Products.CMFDefault:sample_content taken from version.txt. This is
>> deprecated behaviour and will be removed in GenericSetup 1.5: please
>> specify the version in metadata.xml.
>>   DeprecationWarning)
>> C:\Program Files\Plone 3\Data\Products\GenericSetup\registry.py:744:
>> DeprecationWarning: Version for profile Products.CMFTopic:default taken
>> from version.txt. This is deprecated behaviour and will be removed in
>> GenericSetup 1.5: please specify the version in metadata.xml.
>>   DeprecationWarning)
>> C:\Program Files\Plone 3\Data\Products\GenericSetup\registry.py:744:
>> DeprecationWarning: Version for profile Products.CMFUid:default taken
>> from version.txt. This is deprecated behaviour and will be removed in
>> GenericSetup 1.5: please specify the version in metadata.xml.
>>   DeprecationWarning)
>> C:\Program Files\Plone 3\Data\Products\GenericSetup\registry.py:744:
>> DeprecationWarning: Version for profile Products.DCWorkflow:revision2
>> taken from version.txt. This is deprecated behaviour and will be removed
>> in GenericSetup 1.5: please specify the version in metadata.xml.
>>   DeprecationWarning)
>> C:\Program Files\Plone 3\Data\Products\GenericSetup\registry.py:744:
>> DeprecationWarning: Version for profile
>> Products.MimetypesRegistry:MimetypesRegistry taken from version.txt. This
>> is deprecated behaviour and will be removed in GenericSetup 1.5: please
>> specify the version in metadata.xml.
>>   DeprecationWarning)
>> C:\Program Files\Plone 3\Data\Products\GenericSetup\registry.py:744:
>> DeprecationWarning: Version for profile
>> Products.PortalTransforms:PortalTransforms taken from version.txt. This
>> is deprecated behaviour and will be removed in GenericSetup 1.5: please
>> specify the version in metadata.xml.
>>   DeprecationWarning)
>> C:\Program Files\Plone 3\Data\Products\GenericSetup\registry.py:744:
>> DeprecationWarning: Version for profile PluggableAuthService:simple taken
>> from version.txt. This is deprecated behaviour and will be removed in
>> GenericSetup 1.5: please specify the version in metadata.xml.
>>   DeprecationWarning)
>> C:\Program Files\Plone 3\Data\Products\GenericSetup\registry.py:744:
>> DeprecationWarning: Version for profile PluggableAuthService:empty taken
>> from version.txt. This is deprecated behaviour and will be removed in
>> GenericSetup 1.5: please specify the version in metadata.xml.
>>   DeprecationWarning)
>> Traceback (most recent call last):
>>   File "C:\Program Files\Plone 3\Zope\pwi\inno_runner.py", line 30, in ?
>>     execfile(sys.argv[0])
>>   File "C:\Program Files\Plone
>> 3\Data\Products\CMFPlone\Extensions\setupSite.py", line 60, in ?
>>     process(name, swhome, ihome)
>>   File "C:\Program Files\Plone
>> 3\Data\Products\CMFPlone\Extensions\setupSite.py", line 37, in process
>>     out = create(app, admin_username)
>>   File "C:\Program Files\Plone
>> 3\Data\Products\CMFPlone\PloneInitialize.py", line 59, in create
>>     factory.addPloneSite(pid, create_userfolder=1)
>>   File "C:\Program Files\Plone 3\Data\Products\CMFPlone\factory.py", line
>> 85, in addPloneSite
>>     setup_tool.runAllImportStepsFromProfile('profile-%s' % profile_id)
>>   File "C:\Program Files\Plone 3\Data\Products\GenericSetup\tool.py",
>> line 390, in runAllImportStepsFromProfile
>>     ignore_dependencies=ignore_dependencies)
>>   File "C:\Program Files\Plone 3\Data\Products\GenericSetup\tool.py",
>> line 1179, in _runImportStepsFromContext
>>     message = self._doRunImportStep(step, context)
>>   File "C:\Program Files\Plone 3\Data\Products\GenericSetup\tool.py",
>> line 1093, in _doRunImportStep
>>     return handler(context)
>>   File "C:\Program Files\Plone
>> 3\Data\Products\CMFPlone\setuphandlers.py", line 487, in importArchetypes
>>     gen.installArchetypes(site)
>>   File "C:\Program Files\Plone
>> 3\Data\Products\CMFPlone\setuphandlers.py", line 87, in installArchetypes
>>     qi.installProduct('MimetypesRegistry', locked=1, hidden=1,
>> forceProfile=True)
>>   File "C:\Program Files\Plone
>> 3\Data\Products\CMFQuickInstallerTool\QuickInstallerTool.py", line 521,
>> in installProduct
>>     portal_setup.runAllImportStepsFromProfile('profile-%s' % profile)
>>   File "C:\Program Files\Plone 3\Data\Products\GenericSetup\tool.py",
>> line 390, in runAllImportStepsFromProfile
>>     ignore_dependencies=ignore_dependencies)
>>   File "C:\Program Files\Plone 3\Data\Products\GenericSetup\tool.py",
>> line 1179, in _runImportStepsFromContext
>>     message = self._doRunImportStep(step, context)
>>   File "C:\Program Files\Plone 3\Data\Products\GenericSetup\tool.py",
>> line 1093, in _doRunImportStep
>>     return handler(context)
>>   File "C:\Program Files\Plone 3\Data\Products\GenericSetup\tool.py",
>> line 128, in importToolset
>>     new_tool = tool_class(tool_id)
>> TypeError: __init__() takes exactly 1 argument (2 given)
>> 06/26/08 15:23:39: 2872: finished
>> 
>> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Failed-Plone-3.1.2-install-using-Windows-Installer-tp18142190s15482p18263869.html
Sent from the Installation, Setup, Upgrades mailing list archive at Nabble.com.




More information about the Setup mailing list