[Setup] No "Plone Site" listed under Add menu in Zope

Marcel list at webtothemax.com
Sun Jan 6 13:21:07 UTC 2008


Re. to the PIL problem: I had this same problem when I installed PIL  
using easy_install. When using the older "python setup.py install"  
everything was OK again.
Another thing to verify is that the python you are using for Zope is  
really the one you were looking at. So verify that you really have one  
python install on your system.


M.J. Maré
WebToTheMax


On 4 nov 2007, at 19:32, Jinshi Z wrote:

> Hello, everyone,
>
> This is my first message here and I am new to plone. I have some
> trouble to install the plone and I will try to describe as much
> details as I can. And hopefully someone can provide some suggestions.
>
> I am trying to install the whole system on a Windows XP machine.
> Instead of using plone installer, I would like to install each
> component one by one. I first installed python2.4.4 under C:\python24.
> Then I installed Zope2.10.4(binary) under C:\zope\2.10.4 and added an
> instance at C:\zope\instance\2.10.4. I started zope by
> C:\zope\instance\2.10.4\bin\runzope.bat and checked
> localhost:8080/manage and everything ran ok. I then installed PIL
> 1.1.6 and elementtree 1.2.7 using binary package downloaded from
> effbot.org. Then I extracted plone-3.0.2 lib\python and Products
> folders into instance home.
>
> When I ran runzope.bat, I got this error message:
> C:\Zope\Instance\2.10.4\Products\Marshall\config.py:29: UserWarning:  
> libxml2 not
> available. Unable to register libxml2 based marshallers
>  warnings.warn('libxml2 not available. Unable to register libxml2  
> based ' \
>
> In ZMI control panel - products, CMFPlone is not listed. "Plone Site"
> is not listed under the Add menu in ZMI root folder.
>
> I click "error_log" in ZMI root folder page, I got error:
> Error Type: TraversalError
> Error Value: ('No traversable adapter found', {'ignored_exceptions':
> ('Unauthorized', 'NotFound', 'Redirect'), 'keep_entries': 20,
> 'copy_to_zlog': True})
>
> I tried to install libxml2-python-2.6.27.win32-py2.4.exe (downloaded
> from http://xmlsoft.org/sources/win32/python/), the error is still
> there.
>
> I checked the log file: C:\Zope\Instance\2.10.4\log\event.log, the
> most obvious error to me is:
> ImportError: No module named PIL
>
> I do not understand. PIL is in the python24\Lib\site-packages. How can
> I make zope knows about it?
>
> Thanks for any advice.
>
> Jinshi
>
> _______________________________________________
> Setup mailing list
> Setup at lists.plone.org
> http://lists.plone.org/mailman/listinfo/setup





More information about the Setup mailing list