[Setup] Upgrade from 2.1.2 to 3.0.5

TomTiger Fritz.Wittwer at swisscom.com
Fri Feb 15 15:31:41 UTC 2008


Well, I have two products Faqlator ond zwiki (zwiki ist not used). I have
installed them undere 3.0.5 but this makes no difference. 
I could imagine to have a problem with the users and permissions, I played
around with it bit some time ago, there might be a leftover from then.

Is there a way to export just part of a site and import it into another
site? i dont care uch about the users and the FAQs as long as i would be
able to move over the other content.

here is the eventlog I get:

------
2008-02-15T16:13:29 INFO Zope Ready to handle requests
------
2008-02-15T16:20:31 WARNING OFS.Uninstalled Could not import class 'FAQ'
from module 'Products.FAQulator.FAQ'
------
2008-02-15T16:20:57 ERROR Zope.SiteErrorLog
http://sbe22504.corproot.net:8080/SolarisPortal/portal_migration/upgrade
Traceback (innermost last):
  Module Products.CMFQuickInstallerTool.QuickInstallerTool, line 367, in
installProduct
   - __traceback_info__: ('PlonePAS',)
  Module Products.ExternalMethod.ExternalMethod, line 231, in __call__
   - __traceback_info__: ((<PloneSite at /SolarisPortal>,), {}, None)
  Module /opt/data/zope01/Products/PlonePAS/Extensions/Install.py, line 911,
in install
  Module /opt/data/zope01/Products/PlonePAS/Extensions/Install.py, line 360,
in restoreUserData
  Module Products.PlonePAS.tools.membership, line 66, in addMember
  Module Products.PlonePAS.pas, line 49, in _doAddUser
  Module Products.PluggableAuthService.PluggableAuthService, line 941, in
_doAddUser
  Module Products.PluggableAuthService.plugins.ZODBUserManager, line 221, in
doAddUser
  Module Products.PlonePAS.plugins.user, line 68, in addUser
  Module AccessControl.AuthEncoding, line 161, in is_encrypted
TypeError: unsubscriptable object
------
2008-02-15T16:20:57 INFO Plone
Starting the migration from version: 2.1.2
------
2008-02-15T16:20:57 INFO Plone
Attempting to upgrade from: 2.1.2
------
2008-02-15T16:20:57 INFO Plone
Registered tools as utilities.
------
2008-02-15T16:20:57 INFO Plone
Removed vcXMLRPC.js
------
2008-02-15T16:20:57 INFO Plone
Added icons for copy, cut, paste and delete
------
2008-02-15T16:20:57 INFO Plone
Upgrade to: 2.1.3-rc1, completed
------
2008-02-15T16:20:57 INFO Plone
Attempting to upgrade from: 2.1.3-rc1
------
2008-02-15T16:20:57 INFO Plone
Upgrade to: 2.1.3, completed
------
2008-02-15T16:20:57 INFO Plone
Attempting to upgrade from: 2.1.3
------
2008-02-15T16:20:57 INFO Plone
Upgrade to: 2.1.4-rc1, completed
------
2008-02-15T16:20:57 INFO Plone
Attempting to upgrade from: 2.1.4-rc1
------
2008-02-15T16:20:57 INFO Plone
Upgrade to: 2.1.4, completed
------
2008-02-15T16:20:57 INFO Plone
Attempting to upgrade from: 2.1.4
------
2008-02-15T16:20:57 INFO Plone
Registered tools as utilities.
------
2008-02-15T16:20:57 INFO Plone
Added setup_tool.
------
2008-02-15T16:20:57 INFO Plone
Installed CMFPlacefulWorkflow.
------
2008-02-15T16:20:57 INFO Plone
Upgrade to: 2.5-alpha1, completed
------
2008-02-15T16:20:57 INFO Plone
Attempting to upgrade from: 2.5-alpha1
------
2008-02-15T16:20:57 ERROR Plone
Upgrade aborted
------
2008-02-15T16:20:57 ERROR Plone
Error type: exceptions.TypeError
------
2008-02-15T16:20:57 ERROR Plone
Error value: unsubscriptable object
------
2008-02-15T16:20:57 ERROR Plone
  File "/opt/data/zope01/Products/CMFPlone/MigrationTool.py", line 210, in
upgrade
    newv, msgs = self._upgrade(newv)

------
2008-02-15T16:20:57 ERROR Plone
  File "/opt/data/zope01/Products/CMFPlone/MigrationTool.py", line 321, in
_upgrade
    res = function(self.aq_parent)

------
2008-02-15T16:20:57 ERROR Plone
  File "/opt/data/zope01/Products/CMFPlone/migrations/v2_5/alphas.py", line
46, in alpha1_alpha2
    installPlonePAS(portal, out)

------
2008-02-15T16:20:57 ERROR Plone
  File "/opt/data/zope01/Products/CMFPlone/migrations/v2_5/alphas.py", line
66, in installPlonePAS
    installOrReinstallProduct(portal, 'PlonePAS', out)

------
2008-02-15T16:20:57 ERROR Plone
  File "/opt/data/zope01/Products/CMFPlone/migrations/migration_util.py",
line 85, in installOrReinstallProduct
    qi.installProduct(product_name, hidden=hidden)

------
2008-02-15T16:20:57 ERROR Plone
  File
"/opt/data/zope01/Products/CMFQuickInstallerTool/QuickInstallerTool.py",
line 367, in installProduct
    res=install(portal)

------
2008-02-15T16:20:57 ERROR Plone
  File "/usr/local/lib/python/Products/ExternalMethod/ExternalMethod.py",
line 231, in __call__
    try: return f(*args, **kw)

------
2008-02-15T16:20:57 ERROR Plone
  File "/opt/data/zope01/Products/PlonePAS/Extensions/Install.py", line 911,
in install
    restoreUserData(portal, out, userdata)

------
2008-02-15T16:20:57 ERROR Plone
  File "/opt/data/zope01/Products/PlonePAS/Extensions/Install.py", line 360,
in restoreUserData
    mtool.addMember(*u[:5])

------
2008-02-15T16:20:57 ERROR Plone
  File "/opt/data/zope01/Products/PlonePAS/tools/membership.py", line 66, in
addMember
    acl_users._doAddUser(id, password, roles, domains)

------
2008-02-15T16:20:57 ERROR Plone
  File "/opt/data/zope01/Products/PlonePAS/pas.py", line 49, in _doAddUser
    retval = _old_doAddUser(self, login, password, roles, domains)

------
2008-02-15T16:20:57 ERROR Plone
  File
"/opt/data/zope01/Products/PluggableAuthService/PluggableAuthService.py",
line 941, in _doAddUser
    if useradder.doAddUser( login, password ):

------
2008-02-15T16:20:57 ERROR Plone
  File
"/opt/data/zope01/Products/PluggableAuthService/plugins/ZODBUserManager.py",
line 221, in doAddUser
    self.addUser( login, login, password )

------
2008-02-15T16:20:57 ERROR Plone
  File "/opt/data/zope01/Products/PlonePAS/plugins/user.py", line 68, in
addUser
    if not AuthEncoding.is_encrypted(password):

------
2008-02-15T16:20:57 ERROR Plone
  File "/usr/local/lib/python/AccessControl/AuthEncoding.py", line 161, in
is_encrypted
    if pw[:lp] == prefix:

------
2008-02-15T16:20:57 INFO Plone
End of upgrade path, migration has finished
------
2008-02-15T16:20:57 ERROR Plone
The upgrade path did NOT reach current version
------
2008-02-15T16:20:57 ERROR Plone
Migration has failed

Fritz


-- 
View this message in context: http://www.nabble.com/Upgrade-from-2.1.2-to-3.0.5-tp15478377s15482p15502442.html
Sent from the Installation, Setup, Upgrades mailing list archive at Nabble.com.




More information about the Setup mailing list