[Setup] Buildout problems on Vista

aknoerig andre.knoerig at gmail.com
Mon Feb 11 11:31:27 UTC 2008


Never mind, it seems that this was either something only valid yesterday
(server down?) or due to the strange handling of admin rights on Vista. You
really need to explicitly launch cmd.exe with admin rights (right click, or
if it's a link, in the advanced properties).

But, alas, now I am getting this problem related to MinGW's gcc, that I
can't make any sense of:

----
  Installing plone.
  Installing zope2.
  running build_ext
  creating zope.proxy
  copying zope/proxy\proxy.h -> zope.proxy
  building 'AccessControl.cAccessControl' extension
  creating build
  creating build\temp.win32-2.4
  creating build\temp.win32-2.4\Release
  creating build\temp.win32-2.4\Release\accesscontrol
  C:\MinGW\bin\gcc.exe -mno-cygwin -mdll -O -Wall -IExtensionClass -I.
-IAcquisiti
    on -IC:\Python24\include -IC:\Python24\PC -c
AccessControl/cAccessControl.c -o b
    uild\temp.win32-2.4\Release\accesscontrol\caccesscontrol.o
  gcc: installation problem, cannot exec `cc1': No such file or directory
  error: command 'gcc' failed with exit status 1
  While:
    Installing zope2.

  An internal error occured due to a bug in either zc.buildout or in a
recipe being used:

  AssertionError:
------

Again, thanks for any pointers,
andre



aknoerig wrote:
> 
> Hi all,
> 
> I tried to follow the installation instructions as described in Martin's
> book and hit some roadblocks.
> The first ones I could get around by installing Python as well as MinGW
> into directories that contained no spaces.
> But now I'm stuck running the buildout. It gets quite far, up to the point
> where it tries to download and unpack the Plone old-style products:
> 
> ---------
>   [...]
>   Getting distribution for 'five.localsitemanager==0.3'.
>   Got five.localsitemanager 0.3.
>   Getting distribution for 'python-openid>=2.0.0,<2.0.999'.
>   warning: no files found matching 'README' under directory 'examples'
>   warning: no files found matching 'dhpriv' under directory 'openid\test'
>   warning: no files found matching 'n2b64' under directory 'openid\test'
>   zip_safe flag not set; analyzing archive contents...
>   Got python-openid 2.0.1.
>   While:
>     Installing plone.
> 
>   An internal error occured due to a bug in either zc.buildout or in a
>   recipe being used:
> 
>   OSError:
>   [Errno 13] Permission denied:
> 'C:\\Users\\andre\\Zope\\test\\downloads\\GenericSetup-1.3.3.tgz'
> ----------
> 
> In the downloads folder I can see the GenericSetup-1.3.3.tgz file, but it
> has 0 bytes. I am running the command prompt with admin rights, so I don't
> see why there should be problems with permissions.
> 
> I am grateful for any advice, or somebody who experiences the same.
> 
> Best,
> andre
> 

-- 
View this message in context: http://www.nabble.com/Buildout-problems-on-Vista-tp15409361s15482p15409630.html
Sent from the Installation, Setup, Upgrades mailing list archive at Nabble.com.




More information about the Setup mailing list