[Setup] Installing Add-ins

Ricardo Newbery ric at digitalmarbles.com
Mon Feb 11 07:27:44 UTC 2008


On Feb 10, 2008, at 12:14 AM, nickiler wrote:

>
> I installed the Plone version 3.0 on a Windows Server 2003 computer. I
> extracted the add-in and dropped the folder into the "Products"  
> folder in
> both the Zope and Plone install folders. After I restart the Zope  
> server and
> plone server I see nothing. Why don't my packages show up for me to  
> install?
>
> I have tried installing several packages including "PloneBoards" and  
> have
> had no such luck. I am getting ready to scrape this "Plone" in favor  
> of my
> IT manager's "Sharepoint 2007" help!


Your description of your actions sounds odd.

You're adding products to *both* the Zope and Plone "Products"  
folders?  And you're restarting *both* the Zope server and the Plone  
server?

First, don't install add-on products into the Zope "Products" folder.   
That's just likely to confuse you in the future.  In general, all add- 
on products should just go in the "Products" folder of your Plone  
installation (this is a little different for "buildout" installations  
but I doubt you have a buildout install)

Second, there is no Plone server to restart.  Plone runs *inside* a  
Zope server.  I don't understand what you mean when you say you are  
restarting both.

Okay, now to your problem.  I'm afraid you haven't given us enough  
information to help you with but you must be doing something wrong.   
Do you know where your logs are?  Have you checked to see if any error  
messages show up in the logs?

As an aside, please forgive me for dispensing some unsolicited advice  
but sometimes the way a question is framed may discourage people from  
offering to help.  It's most likely that you are just doing something  
incorrectly.  Acknowledging this is the first step toward finding a  
solution.  To my ears, a threat, this early in the game, to "scrape  
Plone in favor of Sharepoint" suggests an attitude toward problem  
solving that almost discouraged me from offering help.

Ric







More information about the Setup mailing list