[Setup] buildout error - need help

Doug Davenport doug at davenportmail.com
Mon Feb 4 21:56:58 UTC 2008


Greetings,

I'm trying to setup a Plone buildout for a non-root user "plone".

So far my environment is:

- fresh install of CentOS 4.6 brought up2date

- as root user, ran a modified version of the Plone 3.0.5 Unified Installler
to setup Python 2.4.4 and other required stuff (commented out install of
zope/plone). This installed python in /opt/plone/Python-2.4.4

- as root user, ran "easy_install ZopeSkel" which setup "Best match:
ZopeSkel 1.5.1"

- modified plone user's profile to pickup new version of python

- as plone user, created project buildout with "paster create -t
plone3_buildout centenary"

- as plone user, bootstrap the buildout with "python bootstrap.py"

- as plone user, build the system with "bin/buildout"
this produced the following output and error:
=====================================
Getting distribution for 'plone.recipe.plone'.
Got plone.recipe.plone 3.0.5.
Getting distribution for 'plone.recipe.distros'.
Got plone.recipe.distros 1.3.
Getting distribution for 'zc.recipe.egg'.
Got zc.recipe.egg 1.0.0.
Getting distribution for 'plone.recipe.zope2install'.
Got plone.recipe.zope2install 1.2.
Getting distribution for 'plone.recipe.zope2instance'.
Got plone.recipe.zope2instance 1.3.
Installing plone.
While:
  Installing plone.

An internal error occured due to a bug in either zc.buildout or in a
recipe being used:

ValueError:
too many values to unpack
=====================================

any ideas what went wrong?

any help is appreciated

thank you,

Doug  

-- 
View this message in context: http://www.nabble.com/buildout-error---need-help-tp15275907s15482p15275907.html
Sent from the Installation, Setup, Upgrades mailing list archive at Nabble.com.




More information about the Setup mailing list