[Setup] Problem updating to 3.0.3

Steve McMahon steve at dcn.org
Thu Nov 15 21:40:08 UTC 2007


Check to see if the version of the Unified Installer that you're using 
has "Rev1" in the downloaded file's name. The first upload was bungled 
(by me) by including gobs of OS X specific files.

aknoerig wrote:
> Hi,
> 
> just tried to update to the newest Plone-3.0.3 via the universal installer.
> Installation process went fine, but when I started the new install, I just
> got long text starting with "No traversable adapter found".
> Also, my Data.fs that I copied from the old install, disappeared (luckily I
> didn't move it).
> 
> This is what "zopectl fg" returns:
> 
> # /opt/Plone-3.0.3/zinstance/bin/zopectl fg
> /opt/Plone-3.0.3/zinstance/bin/runzope -X debug-mode=on
> 2007-11-11 14:07:35 INFO ZServer HTTP server started at Sun Nov 11 14:07:35
> 2007
>         Hostname: 0.0.0.0
>         Port: 8080
> 2007-11-11 14:07:35 INFO Zope Set effective user to "plone"
> 2007-11-11 14:07:39 INFO Marshall libxml2-python not available. Unable to
> register libxml2 based marshallers.
> 2007-11-11 14:07:46 ERROR Application Couldn't install CMFCore
> Traceback (most recent call last):
>   File "/opt/Plone-3.0.3/lib/python/OFS/Application.py", line 786, in
> install_product
>     initmethod(context)
>   File "/opt/Plone-3.0.3/zinstance/Products/CMFCore/__init__.py", line 153,
> in initialize
>     context.registerHelp(directory='interfaces', clear=0)
>   File "/opt/Plone-3.0.3/lib/python/App/ProductContext.py", line 360, in
> registerHelp
>     ht=APIHelpTopic.APIHelpTopic(file, '', os.path.join(path, file))
>   File "/opt/Plone-3.0.3/lib/python/HelpSys/APIHelpTopic.py", line 79, in
> __init__
>     self.title=self.apis[0].name
> IndexError: list index out of range
> Traceback (most recent call last):
>   File "/opt/Plone-3.0.3/lib/python/Zope2/Startup/run.py", line 56, in ?
>     run()
>   File "/opt/Plone-3.0.3/lib/python/Zope2/Startup/run.py", line 21, in run
>     starter.prepare()
>   File "/opt/Plone-3.0.3/lib/python/Zope2/Startup/__init__.py", line 102, in
> prepare
>     self.startZope()
>   File "/opt/Plone-3.0.3/lib/python/Zope2/Startup/__init__.py", line 278, in
> startZope
>     Zope2.startup()
>   File "/opt/Plone-3.0.3/lib/python/Zope2/__init__.py", line 47, in startup
>     _startup()
>   File "/opt/Plone-3.0.3/lib/python/Zope2/App/startup.py", line 102, in
> startup
>     OFS.Application.initialize(application)
>   File "/opt/Plone-3.0.3/lib/python/OFS/Application.py", line 309, in
> initialize
>     initializer.initialize()
>   File "/opt/Plone-3.0.3/lib/python/OFS/Application.py", line 338, in
> initialize
>     self.install_products()
>   File "/opt/Plone-3.0.3/lib/python/OFS/Application.py", line 603, in
> install_products
>     return install_products(app)
>   File "/opt/Plone-3.0.3/lib/python/OFS/Application.py", line 634, in
> install_products
>     folder_permissions, raise_exc=debug_mode)
>   File "/opt/Plone-3.0.3/lib/python/OFS/Application.py", line 786, in
> install_product
>     initmethod(context)
>   File "/opt/Plone-3.0.3/zinstance/Products/CMFCore/__init__.py", line 153,
> in initialize
>     context.registerHelp(directory='interfaces', clear=0)
>   File "/opt/Plone-3.0.3/lib/python/App/ProductContext.py", line 360, in
> registerHelp
>     ht=APIHelpTopic.APIHelpTopic(file, '', os.path.join(path, file))
>   File "/opt/Plone-3.0.3/lib/python/HelpSys/APIHelpTopic.py", line 79, in
> __init__
>     self.title=self.apis[0].name
> IndexError: list index out of range
> 
> Since I did not do anything special and the previous versions all worked
> perfectly, I assume it's a mistake in the universtal installer.
> 

-- 
______________________________________________________

Steve McMahon
Reid-McMahon, LLC
steve at reidmcmahon.com
steve at dcn.org



More information about the Setup mailing list