[Setup] Plone 2.5.3->3 upgrade problems

deesto john.destefano at gmail.com
Thu Nov 8 14:10:12 UTC 2007



Maurits van Rees-3 wrote:
> 
> deesto, on 2007-11-07:
>>
>> In a renewed attempt to migrate, I did the following:
>> - Created a fresh install of Plone 3.0.2 with the universal installer
>> (using
>> the "zeo" option)
>> - Started the Zeo cluster, which created a default Plone site
>> - Shut down the cluster
>> - Deleted the database files in zeocluster/server/var/
>> - Copied *only* Data.fs from the 2.5.3 site to the new installation
>> - Fought with the "admin" password to get to the ZMI
>> - In the ZMI, tried to migrate a site with /portal_migration, but this
>> failed [2]
>> [2] http://paste.plone.org/17816
> 
> Hm, a ConnectionStateError again.  Sometimes just restarting the
> instance helps.
> 

I've seen that too.  I'd restarted several times, even rebooted the machine,
but I kept getting this error.



>> - Deleted /portal_transforms
>> - Tried to add a new Portal Transforms tool, but this failed [3]
>> [3] http://paste.plone.org/17817
> 
> A missing mime type.  The mime type registry needs to be correct
> first; only then can all portal transforms work.  This particular mime
> type is added during the plone migration.  So if you get that running,
> this problem should go away.
> 
> Alternatively, you could delete the mime type registry as well and add
> it again.  I have never done that myself though; same for the Portal
> Transforms.  In case it goes wrong: you do have backups, right? :)
> 

I do have backups, but they'll be in just as bad shape for a migration as
these files!

I was able to easily delete and recreate the mime type registry (I also did
the same for the content type registry, as the migration wouldn't work
without doing so), and then re-add the Portal Transforms tool that I had
deleted ... and then, I was able to migrate the site to v3!  This is great
news.  Thank you Maurits!

There are still some strange things happening, like "file not found"
messages when I click on certain folders under the site root, but I'll see
whether I can figure those out.

Thanks,
~John 
-- 
View this message in context: http://www.nabble.com/Plone-2.5.3-%3E3-upgrade-problems-tf4737493s15482.html#a13647633
Sent from the Installation, Setup, Upgrades mailing list archive at Nabble.com.




More information about the Setup mailing list