[Setup] Re: Plone 2.5.3->3 upgrade problems

Maurits van Rees m.van.rees at zestsoftware.nl
Wed Nov 7 22:55:19 UTC 2007


deesto, on 2007-11-07:
>
> In a renewed attempt to migrate, I did the following:
> - Created a fresh install of Plone 3.0.2 with the universal installer (using
> the "zeo" option)
> - Started the Zeo cluster, which created a default Plone site
> - Shut down the cluster
> - Deleted the database files in zeocluster/server/var/
> - Copied *only* Data.fs from the 2.5.3 site to the new installation
> - Fought with the "admin" password to get to the ZMI
> - In the ZMI, tried to migrate a site with /portal_migration, but this
> failed [2]
> [2] http://paste.plone.org/17816

Hm, a ConnectionStateError again.  Sometimes just restarting the
instance helps.

> - Deleted /portal_transforms
> - Tried to add a new Portal Transforms tool, but this failed [3]
> [3] http://paste.plone.org/17817

A missing mime type.  The mime type registry needs to be correct
first; only then can all portal transforms work.  This particular mime
type is added during the plone migration.  So if you get that running,
this problem should go away.

Alternatively, you could delete the mime type registry as well and add
it again.  I have never done that myself though; same for the Portal
Transforms.  In case it goes wrong: you do have backups, right? :)

-- 
Maurits van Rees | http://maurits.vanrees.org/ [NL]
            Work | http://zestsoftware.nl/
"Do not worry about your difficulties in computers,
 I can assure you mine are still greater."




More information about the Setup mailing list