[Setup] Plone 2.5.3->3 upgrade problems

deesto john.destefano at gmail.com
Fri Nov 2 13:42:27 UTC 2007


I'm trying to upgrade some Plone 2.5.3-final sites on Linux to the latest
version of Plone (3.0.2).  In both cases, I used the universal installer to
install as a Zeo cluster, and moved the data file from the old installation
to the new.

On one site, the Zeo cluster starts, as do the two clients.  I migrated the
site (using plone_migration), and fixed any Product problems that I could
(although some may remain, possibly related to caching).  I can log into the
ZMI, and I can view some objects in the Plone site, but Documents, News, and
Events throw some sort of transform errors.

I can view directories, images, links, Smart Folders (collections), and
files on the site.  The errors I get on the other item types:

Error on viewing the site root ("home") Document item:
http://paste.plone.org/17565
Error on viewing another Document item: http://paste.plone.org/17569
Error on viewing a News item: http://paste.plone.org/17566
Error on viewing an Event item: http://paste.plone.org/17568 

On another site, once I move the Data.fs file from the old site to the new
3.0.2 installation, and try to start the instance with "startcluster", all I
see is "Starting ZEO server ..." and then an infinite series of dots builds
across the screen and run indefinitely (indicating the server never starts).

If I then run "shutdowncluster.sh", it says "daemon manager not running" and
claims to shut down the client processes.  However, checking active
processes shows that the server is indeed still partially running (the
lib/python/ZEO/runzeo.py Python script, and the server/bin/runzeo binary). 
But I can't access the ZMI.

It's odd to see different results for upgrading two sites of the same
version.  Of course, the contents of the first site are very light, while
the second has a great deal of content.

At any rate, I would appreciate any help you can provide into tracking down
the problems.

Thank you,
~John
-- 
View this message in context: http://www.nabble.com/Plone-2.5.3-%3E3-upgrade-problems-tf4737493s15482.html#a13547870
Sent from the Installation, Setup, Upgrades mailing list archive at Nabble.com.




More information about the Setup mailing list